stratos-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Imesh Gunaratne <im...@apache.org>
Subject Re: Cartridge creation error
Date Sat, 23 May 2015 08:48:18 GMT
Hi Asanka,

You could try this without puppet, copy the init.sh script, cartridge agent
and the product distribution you need. Then make sure init.sh script is
properly configured to run on the startup.

Thanks

On Sat, May 23, 2015 at 12:11 PM, Asanka Sanjaya Herath <angal.sh@gmail.com>
wrote:

> Hi All,
>
> I tried to create a php cartridge on GCE using  init.sh[1] and
> config.sh[2]. When I run ./config.sh command it gives me following error. I
> have attached the log file here. Any help is appreciated.
>
>  * Starting puppet
> agent
>
> puppet not configured to start, please edit /etc/default/puppet to enable
>
> [ OK ]
> Processing triggers for libc-bin (2.19-10ubuntu2.3) ...
> Processing triggers for ureadahead (0.100.0-16) ...
> Copying Stratos facter file to /usr/lib/ruby/1.8
>  * Stopping puppet
> agent
> [ OK ]
> Warning: Setting templatedir is deprecated. See
> http://links.puppetlabs.com/env-settings-deprecations
>    (at /usr/lib/ruby/vendor_ruby/puppet/settings.rb:1139:in
> `issue_deprecation_warning')
> Info: Creating a new SSL key for
> 439823051517.default.php.puppet.stratos.com
> Error: Could not request certificate: execution expired
> Exiting; failed to retrieve certificate and waitforcert is disabled
> /bin/rm: cannot remove
> ‘/mnt/apache-stratos-cartridge-agent-4.0.0/wso2carbon.lck’: No such file or
> directory
>
>
> ​[1]​.
> https://raw.githubusercontent.com/apache/stratos/master/tools/init-scripts/init-gce.sh
>
> ​[2].
> https://raw.githubusercontent.com/apache/stratos/master/tools/init-scripts/config-gce.sh
>
> --
> Thanks,
> Regards,
> ASH
>



-- 
Imesh Gunaratne

Senior Technical Lead, WSO2
Committer & PMC Member, Apache Stratos

Mime
View raw message