stratos-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pranavan Theivendiram <pranavan...@cse.mrt.ac.lk>
Subject Re: Build Failure Help
Date Fri, 03 Apr 2015 17:58:07 GMT
The output as requested

Apache Maven 3.0.5
Maven home: /usr/share/maven
Java version: 1.8.0_40-internal, vendor: Oracle Corporation
Java home: /usr/lib/jvm/java-8-openjdk-amd64/jre
Default locale: en_US, platform encoding: UTF-8
OS name: "linux", version: "3.16.0-33-generic", arch: "amd64", family:
"unix"

It seems like my maven version is 3.0.5

*T. Pranavan*
*BSc Eng Undergraduate| Department of Computer Science & Engineering
,University of Moratuwa*
*Intern Software Engineer**| WSO2 Lanka (Pvt) Ltd.*
*Mobile| *0775136836

On 3 April 2015 at 23:22, Udara Liyanage <udara@wso2.com> wrote:

> Hi,
>
> Seems there is an issue with your maven version. Could you send me the
> output of mvn --version
>
> Stratos requires maven 3.0.3 or later
>
> On Fri, Apr 3, 2015 at 11:16 PM, Pranavan Theivendiram <
> pranavan.11@cse.mrt.ac.lk> wrote:
>
>> Hi all,
>>
>> I am getting the following error message when I tried to build the
>> stratos from the github source code,
>>
>> [ERROR] Failed to execute goal
>> org.apache.maven.plugins:maven-enforcer-plugin:1.3.1:enforce (enforce) on
>> project stratos-parent: Some Enforcer rules have failed.
>>
>> Could someone help me on this please?
>>
>> Thanks
>>
>> Regards,
>> *T. Pranavan*
>> *BSc Eng Undergraduate| Department of Computer Science & Engineering
>> ,University of Moratuwa*
>> *Intern Software Engineer**| WSO2 Lanka (Pvt) Ltd.*
>> *Mobile| *0775136836
>>
>
>
>
> --
>
> Udara Liyanage
> Software Engineer
> WSO2, Inc.: http://wso2.com
> lean. enterprise. middleware
>
> web: http://udaraliyanage.wordpress.com
> phone: +94 71 443 6897
>

Mime
View raw message