stratos-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jerad Rutnam <je...@wso2.com>
Subject Re: Can't run strartos server
Date Wed, 04 Mar 2015 04:02:54 GMT
Hi Vishanth, Udara,

Vishanth point seems to be the problem (Dos line ending). It was not built
properly I guess. May be file permission might cause this issue. Anyway I
was able to convert the .sh file to unix using the command:

sed -i s/{ctrl+v}{ctrl+m}// {filename} Thanks,
Jerad

On Tue, Mar 3, 2015 at 4:46 PM, Vishanth Balasubramaniam <vishanthb@wso2.com
> wrote:

> Hi Jerad,
>
> Seems like it has a dos line ending as mentioned in this [1].
>
> [1] -
> http://stackoverflow.com/questions/2920416/configure-bin-shm-bad-interpreter
>
> Thank you,
> Vishanth
>
> On Tue, Mar 3, 2015 at 4:01 PM, Udara Liyanage <udara@wso2.com> wrote:
>
>> Hi jerad,
>>
>> Seems some unknown character is placed in sh file. Could you share the
>> probmatic stratos.sh file
>>
>> On Tue, Mar 3, 2015 at 3:46 PM, Jerad Rutnam <jerad@wso2.com> wrote:
>>
>>> Hi Vishanth,
>>>
>>> You mean the error log after replacing the .sh file? Because there were
>>> no console errors in the initial state.
>>> Except this: *bash: bin/stratos.sh: /bin/sh^M: bad interpreter: No such
>>> file or directory*
>>>
>>> Thanks,
>>> Jerad
>>>
>>> On Tue, Mar 3, 2015 at 3:34 PM, Vishanth Balasubramaniam <
>>> vishanthb@wso2.com> wrote:
>>>
>>>> Hi Jerad,
>>>>
>>>> Could you provide the error log so we can see what went wrong?
>>>>
>>>> Regards,
>>>> Vishanth
>>>>
>>>> On Tue, Mar 3, 2015 at 3:25 PM, Jerad Rutnam <jerad@wso2.com> wrote:
>>>>
>>>>> Hi,
>>>>>
>>>>> I was able to run the server by replacing stratos.sh with an old
>>>>> stratos.sh (but with errors). So I suspect it's something to do with
the
>>>>> build.
>>>>>
>>>>> Thanks,
>>>>> Jerad
>>>>>
>>>>> On Tue, Mar 3, 2015 at 3:19 PM, Jerad Rutnam <jerad@wso2.com> wrote:
>>>>>
>>>>>> Hi,
>>>>>>
>>>>>> I'm having an issue of starting Startos. Please advice me where I
>>>>>> went wrong. Any other configurations I have to do?
>>>>>>
>>>>>> 1.) I built a pack from git [1] last updated source (March 2nd,
>>>>>> 2015).
>>>>>>
>>>>>> 2.) Extracted
>>>>>> stratos/products/stratos/modules/distribution/target/apache-stratos-4.1.0-SNAPSHOT.zip
>>>>>>
>>>>>> 3.) And tried to run the server by using the command "bin/stratos.sh"
>>>>>>
>>>>>> And im getting an error :
>>>>>> *bash: bin/stratos.sh: /bin/sh^M: bad interpreter: No such file or
>>>>>> directory*
>>>>>>
>>>>>> [1] https://github.com/apache/stratos
>>>>>>
>>>>>> Thanks,
>>>>>> Jerad
>>>>>> --
>>>>>> *Jerad Rutnam*
>>>>>> *Software Engineer*
>>>>>>
>>>>>> WSO2 Inc.
>>>>>> lean | enterprise | middleware
>>>>>> M : +94 77 959 1609 | E : jerad@wso2.com | W : www.wso2.com
>>>>>>
>>>>>
>>>>>
>>>>>
>>>>> --
>>>>> *Jerad Rutnam*
>>>>> *Software Engineer*
>>>>>
>>>>> WSO2 Inc.
>>>>> lean | enterprise | middleware
>>>>> M : +94 77 959 1609 | E : jerad@wso2.com | W : www.wso2.com
>>>>>
>>>>
>>>>
>>>>
>>>> --
>>>> *Vishanth Balasubramaniam*
>>>> Software Engineer
>>>> WSO2 Inc.; http://wso2.com
>>>> lean.enterprise.middleware
>>>>
>>>> mobile: *+94771737718*
>>>> about me: *http://about.me/vishanth <http://about.me/vishanth>*
>>>>
>>>>
>>>
>>>
>>> --
>>> *Jerad Rutnam*
>>> *Software Engineer*
>>>
>>> WSO2 Inc.
>>> lean | enterprise | middleware
>>> M : +94 77 959 1609 | E : jerad@wso2.com | W : www.wso2.com
>>>
>>
>>
>>
>> --
>>
>> Udara Liyanage
>> Software Engineer
>> WSO2, Inc.: http://wso2.com
>> lean. enterprise. middleware
>>
>> web: http://udaraliyanage.wordpress.com
>> phone: +94 71 443 6897
>>
>
>
>
> --
> *Vishanth Balasubramaniam*
> Software Engineer
> WSO2 Inc.; http://wso2.com
> lean.enterprise.middleware
>
> mobile: *+94771737718*
> about me: *http://about.me/vishanth <http://about.me/vishanth>*
>
>


-- 
*Jerad Rutnam*
*Software Engineer*

WSO2 Inc.
lean | enterprise | middleware
M : +94 77 959 1609 | E : jerad@wso2.com | W : www.wso2.com

Mime
View raw message