stratos-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dakshika Jayathilaka <daksh...@wso2.com>
Subject Application deployment [deployment-policy-id] return null on 4.1.0-test branch
Date Sun, 14 Dec 2014 13:05:54 GMT
Hi Devs,

when i try to do application deployment i'm getting below info logs.

[2014-12-14 18:29:45,673]  INFO
{org.apache.stratos.rest.endpoint.api.StratosApiV41Utils} -  Starting to
deploy application: [application-id] app_group_v1 *[deployment-policy-id]
null*
[2014-12-14 18:29:45,679]  INFO
{org.apache.stratos.autoscaler.pojo.policy.PolicyManager} -  Deployment
policy is deployed successfully: [id] app_group_v1-8151393899819408994
[2014-12-14 18:29:45,679]  INFO
{org.apache.stratos.autoscaler.client.CloudControllerClient} -  Validating
partitions of policy via cloud controller: [cartridge-type] tomcat
[2014-12-14 18:29:45,694]  INFO
{org.apache.stratos.cloud.controller.services.impl.CloudControllerServiceImpl}
-  All partitions [P1] were validated successfully, against the Cartridge:
tomcat
[2014-12-14 18:29:45,696]  INFO
{org.apache.stratos.autoscaler.client.CloudControllerClient} -  Validating
partitions of policy via cloud controller: [cartridge-type] tomcat1
[2014-12-14 18:29:45,704]  INFO
{org.apache.stratos.cloud.controller.services.impl.CloudControllerServiceImpl}
-  All partitions [P1] were validated successfully, against the Cartridge:
tomcat1
[2014-12-14 18:29:45,706]  INFO
{org.apache.stratos.autoscaler.client.CloudControllerClient} -  Validating
partitions of policy via cloud controller: [cartridge-type] tomcat2
[2014-12-14 18:29:45,714]  INFO
{org.apache.stratos.cloud.controller.services.impl.CloudControllerServiceImpl}
-  All partitions [P1] were validated successfully, against the Cartridge:
tomcat2
[2014-12-14 18:29:45,716]  INFO
{org.apache.stratos.autoscaler.api.AutoScalerServiceImpl} -  The
application Monitor has already been created for [Application] app_group_v1
[2014-12-14 18:29:45,717]  INFO
{org.apache.stratos.rest.endpoint.api.StratosApiV41Utils} -  Application
deployed successfully: [application-id] app_group_v1*
[deployment-policy-id] null*


Seems  * [deployment-policy-id] set to null? *Is this correct?

Thank you

*Dakshika Jayathilaka*
Software Engineer
WSO2, Inc.
lean.enterprise.middleware
0771100911

Mime
View raw message