stratos-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lahiru Sandaruwan <lahi...@wso2.com>
Subject Re: [Grouping] Changing 'kill' Term to 'terminate'
Date Mon, 10 Nov 2014 16:53:04 GMT
It is better to change this term in code as well. Will do some refactoring
when possible.

Thanks.

On Thu, Oct 30, 2014 at 1:35 PM, Isuru Haththotuwa <isuruh@apache.org>
wrote:

> Hi Devs,
>
> Please note that we have renamed the '*kill*' term used in Service Group
> definition and Composite Application Definitions to '*termination*'. This
> is in line with the discussion in the thread [1]. The following are the
> changes that should be applied to the Service Group and Application
> definitions:
>
>    *Old Term *
>
> *New Term*
>
> killBehaviour
>
> terminationBehaviour
>
> kill-none
>
> terminate-none
>
> kill-dependents
>
> terminate-dependents
>
> kill-all
>
> terminate-all
>
>
> Please rename your definitions accordingly, and do let me know if you face
> any issues.
>
> [1]. [Grouping][Part-2] Composite Application Dependency Tree building
> based in Autoscaler
>
>
> --
> Thanks and Regards,
>
> Isuru H.
> +94 716 358 048* <http://wso2.com/>*
>
>
>


-- 
--
Lahiru Sandaruwan
Committer and PMC member, Apache Stratos,
Senior Software Engineer,
WSO2 Inc., http://wso2.com
lean.enterprise.middleware

email: lahirus@wso2.com blog: http://lahiruwrites.blogspot.com/
linked-in: http://lk.linkedin.com/pub/lahiru-sandaruwan/16/153/146

Mime
View raw message