stratos-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chamila De Alwis <chami...@wso2.com>
Subject Cannot subscribe to Docker based cartridge through Kubernetes
Date Fri, 10 Oct 2014 21:50:40 GMT
Hi,

I'm following the m1-guide to setup a Kubernetes Host cluster to test the
Python cartridge agent. However at the subscription step, stratos fails to
subscribe by throwing the following error.

java.net.ConnectException
        at
org.apache.stratos.kubernetes.client.rest.RestClient.doPost(RestClient.java:83)
        at
org.apache.stratos.kubernetes.client.KubernetesApiClient.createReplicationController(KubernetesApiClient.java:243)
        at
org.apache.stratos.cloud.controller.impl.CloudControllerServiceImpl.startContainers(CloudControllerServiceImpl.java:1406)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)


...
...

org.apache.stratos.kubernetes.client.exceptions.*KubernetesClientException:
Error while creating Replication Controller*: ReplicationController
[kind=ReplicationController, id=myphp2.php.domain, resourceVersion=0,
creationTimestamp=null, selfLink=null, apiVersion=v......


I cannot use *kubecfg* commands in the master node, because of the
following error message.

core@master ~ $ kubecfg list pods
*F1010 21:32:14.965547 04785 kubecfg.go:320] Got request error: Get
http://localhost:8080/api/v1beta1/pods?labels=
<http://localhost:8080/api/v1beta1/pods?labels=>: dial tcp 127.0.0.1:8080
<http://127.0.0.1:8080>: connection refused*


The use of port 8080 on my host machine is as follows.


chamilad@chamilad-ThinkPad-T530:~$ *netstat -tunelp | grep 8080*

(Not all processes could be identified, non-owned process info
 will not be shown, you would have to be root to see it all.)
tcp        0      0 *127.0.0.1:8080 <http://127.0.0.1:8080>
0.0.0.0:*               LISTEN      0          133583      -*
tcp6       0      0 ::1:8080                :::*
LISTEN      0          133582      -



I have tried this with both the four-node and the two-node setup and ended
up at the same error message.

The wso2carbon.log and json files used to create Kubernetes host and
subscribe to cartridge are attached.



Regards,
Chamila de Alwis
Software Engineer | WSO2 | +94772207163
Blog: code.chamiladealwis.com

Mime
View raw message