stratos-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Roshan Deniyage <rosh...@wso2.com>
Subject Re: Issue in artifact deployment
Date Thu, 04 Sep 2014 05:08:47 GMT
I'm using packs built from 4.0.0 release tag. The issue is that, it sync
with git repo but erase the existing default apps inside the webapps folder
of my tomcat cartridge.

Roshan Deniyage
​
WSO2, Inc: http://wso2.com

Mobile    :  +94 777636406
Twitter    :  *https://twitter.com/roshku <https://twitter.com/roshku>*
LinkedIn :  https://www.linkedin.com/in/roshandeniyage



On Wed, Sep 3, 2014 at 9:44 PM, Isuru Haththotuwa <isuruh@apache.org> wrote:

> Hi Roshan,
>
> Are you using Stratos 4.0.0 packs or packs built from the master branch?
>
>
> On Wed, Sep 3, 2014 at 7:43 PM, Roshan Deniyage <roshand@wso2.com> wrote:
>
>> Hi devs,
>>     This is regarding tomcat cartridge creation. I have spawned an
>> instance with fully configured tomcat cartridge. When I setup git
>> repository to pull sample web application to tomcat cartridge, it replace
>> the whole webapps folder with the sample.
>> Is there any configuration to tell 'artifact deployment synchronize' of
>> the cartridge agent to only copy the sample application to the relevant
>> folder, without deleting the existing ones?
>>
>> Thanks,
>>
>> ​​
>> Roshan Deniyage
>> ​
>> WSO2, Inc: http://wso2.com
>>
>> Mobile    :  +94 777636406
>> Twitter    :  *https://twitter.com/roshku <https://twitter.com/roshku>*
>> LinkedIn :  https://www.linkedin.com/in/roshandeniyage
>>
>> --
>> <https://www.linkedin.com/in/roshandeniyage>
>> Thanks and Regards,
>>
>> Isuru H.
>> <https://www.linkedin.com/in/roshandeniyage>
>> +94 716 358 048 <https://www.linkedin.com/in/roshandeniyage>*
>> <http://wso2.com/>*
>>
>>
>> * <http://wso2.com/>*
>>
>>
>>

Mime
View raw message