stratos-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Udara Liyanage <ud...@wso2.com>
Subject Re: Subscribe Cartbrigde Multitenant
Date Thu, 14 Aug 2014 12:52:50 GMT
Hi,

Error says that there is no any active instance of type centos.

If you successfully deploy a service of centos, an instance of centos
should be spawned, related server/service should start running , then
 cartridge agent send instance activated event. Only after cartridge agent
sends instance activated event, Stratos will allow you to subscribe to a
multy tenant cartridge.




On Thu, Aug 14, 2014 at 6:11 PM, Ignacio Ayuste <
ignacio.ayuste@bairesdev.com> wrote:

> hello guys, im trying to subscribe a multitenant cartbridbe i follow all
> the wizard and every works perfect but when i try to subscribe the
> cartbridge give me this error in the log file.
>
>  TID: [0] [STRATOS] [2014-08-11 23:34:03,345] ERROR
> {org.apache.stratos.manager.m
> anager.CartridgeSubscriptionManager} -  No active instances are found for
> cartri
> dge [centos]
> {org.apache.stratos.manager.manager.CartridgeSubscriptionManager}
>
> Im using Statos 4.0.0 with docker in an image EC2 in the cloud.
>
> i follow the source code and found this method
>
> private boolean activeInstancesAvailable(SubscriptionData
> subscriptionData) {
>       Cluster cluster =
> TopologyClusterInformationModel.getInstance().getCluster(subscriptionData.getCartridgeType());
>       int activeMemberCount = 0;
>       if(cluster != null) {
>           Collection<Member> members = cluster.getMembers();
>           for (Member member : members) {
>   if(member.isActive()) {
>   activeMemberCount++;
>   }
>   }
>       }
>       if(log.isDebugEnabled()) {
>       log.debug("Active member count for cluster  [" + cluster +"] is :
> "+ activeMemberCount);
>       }
>   return activeMemberCount > 0;
> }
>
> can you explain me more about this or give me an example to configure
> multitenant cartbrige.
>
> im from Argentina sorry is my english is note clear, let me know.
>
> PD: Also when i try to subscribe a multitenant cartbrige without add a
> load balancer gives me NPE i thinks there is a bug there.
>
> TID: [0] [STRATOS] [2014-08-13 16:19:07,713] ERROR
> {org.apache.stratos.rest.endp
> oint.services.ServiceUtils} -  Failed to deploy the Service [Cartridge
> type] cen
> tos [alias] 027982ef-475e-4be4-945f-734eb5d54985 . Cause: null
> {org.apache.strat
> os.rest.endpoint.services.ServiceUtils}
> java.lang.NullPointerException
>         at
> org.apache.stratos.manager.deploy.service.ServiceDeploymentManager.de
> ployService(ServiceDeploymentManager.java:322)
>         at
> org.apache.stratos.rest.endpoint.services.ServiceUtils.deployService(
> ServiceUtils.java:1133)
>         at
> org.apache.stratos.rest.endpoint.services.StratosAdmin.deployService(
> StratosAdmin.java:908)
>
>
> Thanks for the help
> Ignacio
>
>


-- 

Udara Liyanage
Software Engineer
WSO2, Inc.: http://wso2.com
lean. enterprise. middleware

web: http://udaraliyanage.wordpress.com
phone: +94 71 443 6897

Mime
View raw message