stratos-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sajith Kariyawasam <saj...@wso2.com>
Subject Re: Cartridge Creation Issue
Date Wed, 13 Aug 2014 10:19:25 GMT
Hi Roshan,

You have got an  "Invalid key_name provided.", so you seems to have given a
key pair name which is not available in Openstack.
Please check the tomacat cartridge json file, and cross check the Openstack
whether that key pair is available.

Thanks,
Sajith


On Wed, Aug 13, 2014 at 3:32 PM, Roshan Deniyage <roshand@wso2.com> wrote:

> Hi All,
>     I deployed openstack using devstack with docker support for
> development purposes. That works fine. Then, stratos was deployed with
> openstack as IaaS. stratos also seems good.
> Then, tomcat cartridge was created and when try to subscribe to a
> cartridge, new instance is not starting and the following error is given.
>
>
>
> --------------------------------------------------------------------------------------------------------------------------
> Caused by: org.jclouds.http.HttpResponseException: command: POST
> http://10.0.2.15:8774/v2/ec7497f22d7e46718bd4b90a3d39da05/servers
> HTTP/1.1 failed with response: HTTP/1.1 400 Bad Request; content:
> [{"badRequest": {"message": "Invalid key_name provided.", "code": 400}}]
>
>
> ---------------------------------------------------------------------------------------------------------------------------
> [STRATOS] [2014-08-13 09:11:11,199] ERROR
> {org.apache.axis2.rpc.receivers.RPCMessageReceiver} -  Failed to start an
> instance. MemberContext [memberId=tomcat.tomcat.domaine8f2991b-3195-4aca
> -a70d-c4df889174f0, nodeId=null, clusterId=tomcat.tomcat.domain,
> cartridgeType=tomcat, privateIpAddress=null, publicIpAddress=null,
> allocatedIpAddress=null, initTime=1407921070771, lbClusterId=null
> , networkPartitionId=openstack] Cause: error running 1 node
> group(tomcattom) location(RegionOne)
> image(2a143fd7-e195-48b2-8771-1adfb1c3e94e) size(2)
> options({inboundPorts=[], autoAssignFloatingIp=f
> alse, keyPairName=demo, userData=[B@209481cf, configDrive=false})
> Execution failures:
>
> -----------------------------------------------------------------------------------------------------------------------------
>
> Anyone has idea, what going on?
>
>
> Roshan Deniyage
> ‚Äč
> WSO2, Inc: http://wso2.com
>
> Mobile    :  +94 777636406
> Twitter    :  *https://twitter.com/roshku <https://twitter.com/roshku>*
> LinkedIn :  https://www.linkedin.com/in/roshandeniyage
>
>


-- 
*--*
*Sajith Kariyawasam*
*Mobile: +94772269575*

Mime
View raw message