stratos-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Damitha Kumarage (JIRA)" <j...@apache.org>
Subject [jira] [Created] (STRATOS-638) Tomcat Cartridge instance shown as active in UI, but tomcat web server not started
Date Wed, 30 Apr 2014 04:25:15 GMT
Damitha Kumarage created STRATOS-638:
----------------------------------------

             Summary: Tomcat Cartridge instance shown as active in UI, but tomcat web server
not started
                 Key: STRATOS-638
                 URL: https://issues.apache.org/jira/browse/STRATOS-638
             Project: Stratos
          Issue Type: Bug
          Components: Cartridge Agent
    Affects Versions: 4.0.0 RC1
         Environment: Stratos UI. Openstack/Docker IaaS
            Reporter: Damitha Kumarage


I can create cartridge, then create tenant and subscribe to that cartridge from UI. Also I
can see active instance of tomcat cartridge created from Stratos UI. However Tomcat web server
is not started in the cartridge instance. When I see /var/log/stratos_init.log there is no
sign of failures. I have attached that file here. When I see tomcat log it says
---
/mnt/apache-tomcat-7.0.52/bin/catalina.sh: 1: eval: /opt/java/bin/java: not found
----

>From stratos_init.log below I suspect Tomcat is started before Java is ready in the instance.

-------
[[0;36mnotice: /Stage[main]/Tomcat/File[/mnt/apache-tomcat-7.0.52/conf/server.xml]/content:
content changed '{md5}243c711930a975db7507077c41bde651' to '{md5}49939d8265ce59858f59d0e9dbc8ed39'^[[0m
^[[0;36mnotice: /Stage[main]/Tomcat/Exec[Set tomcat home permission]/returns: executed successfully^[[0m
^[[0;36mnotice: /Stage[main]/Tomcat/Exec[Start tomcat]/returns: executed successfully^[[0m
--------
When I log into the cartidge instance and manually start Tomcat it work fine and I can access
Tomcat sample web applications.

I tried this several times and each problem remain.

Regarding my puppet installation, I copied all files from puppet3/manifests and puppet3/modules
from RC1 source to my old puppet setup configured and restarted puppet master.





--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message