stratos-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Damitha Kumarage (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (STRATOS-573) Does not show created cartridges for subscribing
Date Fri, 04 Apr 2014 07:39:14 GMT

     [ https://issues.apache.org/jira/browse/STRATOS-573?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Damitha Kumarage updated STRATOS-573:
-------------------------------------

    Attachment: tomcat.json
                deployment-policy.jason
                autoscale-policy.jason
                partition.jason

> Does not show created cartridges for subscribing
> ------------------------------------------------
>
>                 Key: STRATOS-573
>                 URL: https://issues.apache.org/jira/browse/STRATOS-573
>             Project: Stratos
>          Issue Type: Bug
>         Environment: Openstack IaaS
>            Reporter: Damitha Kumarage
>         Attachments: autoscale-policy.jason, deployment-policy.jason, partition.jason,
tomcat.json
>
>
> I have setup Stratos(single jvm) from master(cloned on 29March2014) with a standalone
load balancer. My IaaS is Openstack. 
> I deployed a partition, autoscale policy, deployment policy and a tomcat cartridge(json
files attached) through the UI console logged in as admin. It says successful deployment after
running the wizard. In the stratos server backend also it says successfully deployed tomcat
cartridge. But I cannot see any cartridge, logged in as admin or from my created tenant.
> Note that in the wizard I skipped lb cartridge section because I deploy my lb separately.
In the tomcat cartridge json I kept loadbalancer section with empty brackets as
>  "loadBalancer": {}
> I tried to deploy above with cli as well. There also in the stratos back end it says
successful deployment of cartridge but when I do "list-cartridge" it says
> ----------------
> Cannot find any deployed multi-tenant Cartridge. Please deploy a Cartridge using [deploy-cartridge]
command.
> Cannot find any deployed single-tenant Cartridge. Please deploy a Cartridge using [deploy-cartridge]
command
> ------------------
> Also note that when deploying partition, autoscale policy and deployment policy, both
in the UI and cli cases, the Stratos back end does not show any success or failure messages.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message