stratos-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jeffrey Nguyen (jeffrngu)" <jeffr...@cisco.com>
Subject Re: Broken link on Single JVM Wiki
Date Wed, 16 Apr 2014 00:32:33 GMT
Thanks Nirmal!  Please see further questions under [Jeffrey]

From: Nirmal Fernando <nirmal070125@gmail.com<mailto:nirmal070125@gmail.com>>
Reply-To: "dev@stratos.incubator.apache.org<mailto:dev@stratos.incubator.apache.org>"
<dev@stratos.incubator.apache.org<mailto:dev@stratos.incubator.apache.org>>
Date: Tuesday, April 15, 2014 3:57 PM
To: "dev@stratos.incubator.apache.org<mailto:dev@stratos.incubator.apache.org>" <dev@stratos.incubator.apache.org<mailto:dev@stratos.incubator.apache.org>>
Subject: Re: Broken link on Single JVM Wiki

Hi Jeffrey,


On Wed, Apr 16, 2014 at 5:17 AM, Jeffrey Nguyen (jeffrngu) <jeffrngu@cisco.com<mailto:jeffrngu@cisco.com>>
wrote:
Hi Nirmal,

I'm trying out the single JVM install now.  Couple of questions:

  1.  In setup.sh, ~line 600 "cp -R $mb_client_lib_path/* $stratos_extract_path/repository/components/lib",
which files are we expecting to copy and where can I get them?

In ActiveMQ case, you don't need to provide any additional jars, you can simply press enter
if you are prompted. I'll add this to the wiki as a note.

  1.  In the silence mode, it seems we need to set the value for "mb_client_lib_path" in setup.conf
because user is not prompted to enter this value?

In silence mode, we expect you have all-set pack :-)
[Jeffrey] Not sure what you meant by "all-set pack" but since I'm using ActiveMQ, based on
your comment above, I can ignore.


  1.  In setup.conf, can I use valid IP for "stratos_domain" or does it need to be a valid
host name?

It should be a host name, and you can use it to access stratos. This host name will be mapped
to the correct IP.


  1.  I'm used to seeing different deployment directories of various Stratos components (AS,
CC, SM, CEP).  With this single JVM installation, how do I verify that these components are
installed and started successfully?

Well, you get all of them :-) Why you want to verify?

[Jeffrey] I need to see what gets created/installed where so I can apply this to our custom
deployment process.   Also, it's good to know so when you need to debug single JVM install
process.  Like right now, my install log is clean of errors.  However, I cannot access the
link to Stratos console.


  1.  Just to clarify, in the old deployment model where each Stratos component runs in their
own profile and JVM.  Whereas with "multi-profile single JVM", we have just a single JVM process
that has multiple profiles and has many functions: AS, CC, SM, CEP, correct?

Using multi-profile product, you can either start all stratos components in a single JVM or
else you can start AS, CC, SM in 3 separate JVMs too by using eg: ./setup.sh -pcc

[Jeffrey] Is that "-pcc" or "-p cc"?   Also, are you saying I need to run "setup.sh" 3 times,
each with different options: cc, as, and sm?

Thanks,
-Jeffrey

From: Nirmal Fernando <nirmal070125@gmail.com<mailto:nirmal070125@gmail.com>>
Reply-To: "dev@stratos.incubator.apache.org<mailto:dev@stratos.incubator.apache.org>"
<dev@stratos.incubator.apache.org<mailto:dev@stratos.incubator.apache.org>>
Date: Tuesday, April 15, 2014 1:16 PM

To: "dev@stratos.incubator.apache.org<mailto:dev@stratos.incubator.apache.org>" <dev@stratos.incubator.apache.org<mailto:dev@stratos.incubator.apache.org>>
Subject: Re: Broken link on Single JVM Wiki

Well, we could.. but we're currently testing on 5.8. But may be you could try with 5.9.1.
You might need to configure setup.conf etc. though.


On Wed, Apr 16, 2014 at 2:33 AM, Jeffrey Nguyen (jeffrngu) <jeffrngu@cisco.com<mailto:jeffrngu@cisco.com>>
wrote:
Thanks Nirmal!  That new link works!  Is there any reason to not using the latest stable version
which is 5.9.1?

-Jeffrey

From: Nirmal Fernando <nirmal070125@gmail.com<mailto:nirmal070125@gmail.com>>
Reply-To: "dev@stratos.incubator.apache.org<mailto:dev@stratos.incubator.apache.org>"
<dev@stratos.incubator.apache.org<mailto:dev@stratos.incubator.apache.org>>
Date: Tuesday, April 15, 2014 12:58 PM

To: "dev@stratos.incubator.apache.org<mailto:dev@stratos.incubator.apache.org>" <dev@stratos.incubator.apache.org<mailto:dev@stratos.incubator.apache.org>>
Subject: Re: Broken link on Single JVM Wiki

Done. Thanks.


On Wed, Apr 16, 2014 at 2:27 AM, Nirmal Fernando <nirmal070125@gmail.com<mailto:nirmal070125@gmail.com>>
wrote:

Hi Jeffrey,

Sorry, seems like you are right, it is not working... I'll edit the wiki page till that you
can use http://repository.apache.org/content/repositories/releases/org/apache/activemq/apache-activemq/5.8.0/apache-activemq-5.8.0-bin.tar.gz


On Tue, Apr 15, 2014 at 11:42 PM, Isuru Perera <isurup@wso2.com<mailto:isurup@wso2.com>>
wrote:
Hi Jeffrey, I could also access the link given in the wiki.

However we should also add instructions to download the ActiveMQ from http://activemq.apache.org

I will work on that when I get some time.


On Tue, Apr 15, 2014 at 11:38 PM, Jeffrey Nguyen (jeffrngu) <jeffrngu@cisco.com<mailto:jeffrngu@cisco.com>>
wrote:
Strange!  It always takes me to a mirror page.  I tried several links on that page and none
worked with the error below.

Not Found

The requested URL /activemq/apache-activemq/5.8.0/apache-activemq-5.8.0-bin.tar.gz was not
found on this server.


-Jeffrey

From: Nirmal Fernando <nirmal070125@gmail.com<mailto:nirmal070125@gmail.com>>
Reply-To: "dev@stratos.incubator.apache.org<mailto:dev@stratos.incubator.apache.org>"
<dev@stratos.incubator.apache.org<mailto:dev@stratos.incubator.apache.org>>
Date: Tuesday, April 15, 2014 9:57 AM
To: "dev@stratos.incubator.apache.org<mailto:dev@stratos.incubator.apache.org>" <dev@stratos.incubator.apache.org<mailto:dev@stratos.incubator.apache.org>>
Subject: Re: Broken link on Single JVM Wiki

Hi Jeffrey,

I could access [1]. You can select a mirror from there.


On Tue, Apr 15, 2014 at 11:23 PM, Jeffrey Nguyen (jeffrngu) <jeffrngu@cisco.com<mailto:jeffrngu@cisco.com>>
wrote:
Hi,

On https://cwiki.apache.org/confluence/display/STRATOS/4.0.0+Single+JVM+Product+Configuration,
step #4: link to activeMQ 5.8.0 at [1] is broken.   Can we use 5.9.1 at [2] instead?

[1]  http://www.apache.org/dyn/closer.cgi?path=/activemq/apache-activemq/5.8.0/apache-activemq-5.8.0-bin.tar.gz
[2] http://www.apache.org/dyn/closer.cgi?path=/activemq/5.9.1/apache-activemq-5.9.1-bin.tar.gz

-Jeffrey



--
Best Regards,
Nirmal

Nirmal Fernando.
PPMC Member & Committer of Apache Stratos,
Senior Software Engineer, WSO2 Inc.

Blog: http://nirmalfdo.blogspot.com/



--
Isuru Perera
Senior Software Engineer | WSO2, Inc. | http://wso2.com/
Lean . Enterprise . Middleware

about.me/chrishantha<http://about.me/chrishantha>



--
Best Regards,
Nirmal

Nirmal Fernando.
PPMC Member & Committer of Apache Stratos,
Senior Software Engineer, WSO2 Inc.

Blog: http://nirmalfdo.blogspot.com/



--
Best Regards,
Nirmal

Nirmal Fernando.
PPMC Member & Committer of Apache Stratos,
Senior Software Engineer, WSO2 Inc.

Blog: http://nirmalfdo.blogspot.com/



--
Best Regards,
Nirmal

Nirmal Fernando.
PPMC Member & Committer of Apache Stratos,
Senior Software Engineer, WSO2 Inc.

Blog: http://nirmalfdo.blogspot.com/



--
Best Regards,
Nirmal

Nirmal Fernando.
PPMC Member & Committer of Apache Stratos,
Senior Software Engineer, WSO2 Inc.

Blog: http://nirmalfdo.blogspot.com/

Mime
View raw message