stratos-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Akila Ravihansa Perera <raviha...@wso2.com>
Subject Re: Failed to execute configuration script on cartridge instance
Date Thu, 10 Apr 2014 19:58:40 GMT
Hi Nirmal,

The problem was by some chance autosign.conf file on Puppet master has been
made executable...which made Puppet master to reject all cert requests
coming from Puppet agents.

As for the scripts provided, there is no script to configure the Puppet
master. That has to be done manually anyway. I followed the Wiki guide in
[1].

[1] -
https://cwiki.apache.org/confluence/display/STRATOS/4.0.0+Configuring+Puppet+Master

It would be nice to have a script to configure Puppet master :)


On Fri, Apr 11, 2014 at 1:19 AM, Nirmal Fernando <nirmal070125@gmail.com>wrote:

> Hi Akila,
>
> Were you doing things manually or were you using the scripts that we
> provide? If you use our scripts and follow the steps you shouldn't have run
> into this issue, but if you did please help us to improve the docs.
>
>
> On Thursday, April 10, 2014, Akila Ravihansa Perera <ravihansa@wso2.com>
> wrote:
>
>> Hi,
>>
>> Managed to resolve this issue. Wanted to make some notes for future
>> reference.
>>
>> 1. Remove ssl directory in puppet master and agent [1] :  sudo rm -rf
>> /var/lib/puppet/ssl
>> 2. Restart the puppet master service after cleaning up all
>> certificates/requests
>> 3. autosign.conf must *NOT* be executable [2]....this was the major
>> blocker, took 2 days to figure that out!
>>
>> Hope this will help those who experience the same.
>>
>> [1] - https://groups.google.com/forum/#!topic/puppet-users/JIz9k06VYQk
>> [2] -
>> http://docs.puppetlabs.com/puppet/latest/reference/ssl_autosign.html
>>
>>
>>
>> On Thu, Apr 10, 2014 at 3:46 PM, Sajith Kariyawasam <sajith@wso2.com>wrote:
>>
>> On Thu, Apr 10, 2014 at 3:32 PM, Akila Ravihansa Perera <
>> ravihansa@wso2.com> wrote:
>>
>> Hi,
>>
>> Pl see inline
>>
>>
>> On Thu, Apr 10, 2014 at 2:25 PM, Sajith Kariyawasam <sajith@wso2.com>wrote:
>>
>> Hi Akila,
>>
>> Please verify following,
>>
>> Does your puppet master's nodes.pp contain a block which matches the
>> generated domain "355510041424.default.default.puppet.puppet.localhost" ?
>>
>>
>> No. Where does this happen? I just copied puppet master files from
>> Stratos tools [1] and followed the create cartridge guide in the Wiki.
>>
>>
>>
>> It seems that when executing config script  you have given the
>> service-name as "default".
>> [Please provide stratos service-name:default]
>>
>> Based on the provided name it will generate the domain. And there should
>> be a matching pattern in nodes.pp.
>>
>> For eg, in nodes.pp of [1]  there is a node with /php/ pattern, which
>> will execute if the domain name has a string php.
>> Therefore if you need to create a php cartridge, you should provide the
>> service-name as "php", and then your generated domain will be something like
>> "355510041424.php.default.puppet.puppet.localhost"
>>
>>
>>
>>
>>  Also it seems some puppet configs in Puppet Master, tries to delete the
>> wso2carbo
>>
>>
>
> --
> Best Regards,
> Nirmal
>
> Nirmal Fernando.
> PPMC Member & Committer of Apache Stratos,
> Senior Software Engineer, WSO2 Inc.
>
> Blog: http://nirmalfdo.blogspot.com/
>
>


-- 
Akila Ravihansa Perera
Software Engineer
WSO2 Inc.
http://wso2.com

Phone: +94 77 64 154 38
Blog: http://ravihansa3000.blogspot.com

Mime
View raw message