stratos-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nirmal Fernando <nirmal070...@gmail.com>
Subject Re: Are we using amqp port (5672) in ActiveMQ for stratos?
Date Thu, 17 Apr 2014 04:38:00 GMT
Thanks Dinesh for bringing this up. Now, I too wonder may be we should use
AMQP transport instead of direct TCP transport.
Can you do a test round only with AMQP transport?




On Thu, Apr 17, 2014 at 9:52 AM, Dinesh Bandara <dineshb@wso2.com> wrote:

> Hi Devs,
>
> There were couple of threads regarding the issues with AMQP port.
> Therefore I just tried out basic stratos setup with ActiveMQ by disabling
> AMQP.
>
> Commented out following line in <ACTIVEMQ_HOME>/conf/activemq.xml
> <transportConnector name="amqp" uri="amqp://
> 0.0.0.0:5672?maximumConnections=1000&amp;wireformat.maxFrameSize=104857600<http://0.0.0.0:5672?maximumConnections=1000&wireformat.maxFrameSize=104857600>
> "/>
>
> When I looked into jndi.properties file in stratos. We have used openwire
> instead of amqp.
> java.naming.provider.url=tcp://<mb_ip>:61616
>
> Without amqp I was able to run startos and its features successfully.
>
> I'm glad if someone can verify the $subject
>
> Thanks.
>
> --
> *Dinesh Bandara*
> Software Engineer
> WSO2 Inc.; http://wso2.com
> lean.enterprise.middleware
>
>


-- 
Best Regards,
Nirmal

Nirmal Fernando.
PPMC Member & Committer of Apache Stratos,
Senior Software Engineer, WSO2 Inc.

Blog: http://nirmalfdo.blogspot.com/

Mime
View raw message