stratos-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nirmal Fernando <nirmal070...@gmail.com>
Subject Re: Error when deploying Openstack cartridge in M6
Date Sat, 22 Feb 2014 12:02:39 GMT
Hi Damitha,

Yes, if you can move to master, that's great. Also, did you restart CC or
redeploy cartridges after changing the cloud-controller,xml?


On Sat, Feb 22, 2014 at 5:17 PM, Lakmal Warusawithana <lakmal@wso2.com>wrote:

> Hi Damitha,
>
> I think its good to go with master.(latest) It is more stable now.
>
> thanks
>
>
> On Sat, Feb 22, 2014 at 5:14 PM, damitha kumarage <damitha23@gmail.com>wrote:
>
>> I tried with a valid imag id as well but the same result. Since this is
>> fixed in the master, may be I'll try with M7 then.
>>
>> Thanks,
>> Damitha
>>
>>
>> On Sat, Feb 22, 2014 at 4:45 PM, Nirmal Fernando <nirmal070125@gmail.com>wrote:
>>
>>> Ok, I wasn't sure what's the status of M6 was. May be you can try adding
>>> a valid image id there. But we have fixed this issue in master.
>>>
>>>
>>> On Sat, Feb 22, 2014 at 4:42 PM, damitha kumarage <damitha23@gmail.com>wrote:
>>>
>>>> Thanks for the very quick reply Nirmal,
>>>> It still give null pointer exception
>>>>
>>>> Damitha
>>>>
>>>>
>>>> On Sat, Feb 22, 2014 at 4:14 PM, Nirmal Fernando <
>>>> nirmal070125@gmail.com> wrote:
>>>>
>>>>> Hi Damitha,
>>>>>
>>>>> Can you set an empty value to the <imageId>nova/</imageId>
element of
>>>>> cloud-controller.xml and try please?
>>>>>
>>>>>
>>>>> On Sat, Feb 22, 2014 at 4:10 PM, damitha kumarage <damitha23@gmail.com
>>>>> > wrote:
>>>>>
>>>>>> Hi Devs,
>>>>>> I am in the process of creating a Python cartridge. When I use a
>>>>>> simple java class(attached JCloudsNova.java ) using jclouds api to
create
>>>>>> an instance of the cartridge image it is created. But when I use
the
>>>>>> stratos cli to deploy the cartridge using the same Openstack details,
it
>>>>>> fails. I have attached my
>>>>>> 1) python_cartridge.jason
>>>>>> 2) CC log(wso2carbon.log.cc)
>>>>>> 3) SC log(wso2carbon.log.sc)
>>>>>> 4) cloud-controller.xml
>>>>>> Also note that all my carbon servers started without any errors.
>>>>>>
>>>>>> It is a nullpointer exception in CC. Please let me understand where
>>>>>> it went wrong.
>>>>>>
>>>>>> Thanks,
>>>>>> Damitha
>>>>>>
>>>>>>
>>>>>>
>>>>>> --
>>>>>> __________________________________________________________________
>>>>>> Damitha Kumarage
>>>>>> http://people.apache.org/
>>>>>> __________________________________________________________________
>>>>>>
>>>>>
>>>>>
>>>>>
>>>>> --
>>>>> Best Regards,
>>>>> Nirmal
>>>>>
>>>>> Nirmal Fernando.
>>>>> PPMC Member & Committer of Apache Stratos,
>>>>> Senior Software Engineer, WSO2 Inc.
>>>>>
>>>>> Blog: http://nirmalfdo.blogspot.com/
>>>>>
>>>>
>>>>
>>>>
>>>> --
>>>> __________________________________________________________________
>>>> Damitha Kumarage
>>>> http://people.apache.org/
>>>> __________________________________________________________________
>>>>
>>>
>>>
>>>
>>> --
>>> Best Regards,
>>> Nirmal
>>>
>>> Nirmal Fernando.
>>> PPMC Member & Committer of Apache Stratos,
>>> Senior Software Engineer, WSO2 Inc.
>>>
>>> Blog: http://nirmalfdo.blogspot.com/
>>>
>>
>>
>>
>> --
>> __________________________________________________________________
>> Damitha Kumarage
>> http://people.apache.org/
>> __________________________________________________________________
>>
>
>
>
> --
> Lakmal Warusawithana
> Software Architect; WSO2 Inc.
> Mobile : +94714289692
> Blog : http://lakmalsview.blogspot.com/
>
>


-- 
Best Regards,
Nirmal

Nirmal Fernando.
PPMC Member & Committer of Apache Stratos,
Senior Software Engineer, WSO2 Inc.

Blog: http://nirmalfdo.blogspot.com/

Mime
View raw message