stratos-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "chris snow (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (STRATOS-170) `mvn install` issue - LoadBalancerExtension.java:[45,5] error: annotations are not supported in -source 1.3
Date Sat, 09 Nov 2013 19:55:17 GMT

     [ https://issues.apache.org/jira/browse/STRATOS-170?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

chris snow updated STRATOS-170:
-------------------------------

    Attachment: 0045-Add-maven-enforcer-plugin-to-ensure.patch

added patch created using `git format-patch`

> `mvn install` issue - LoadBalancerExtension.java:[45,5] error: annotations are not supported
in -source 1.3
> -----------------------------------------------------------------------------------------------------------
>
>                 Key: STRATOS-170
>                 URL: https://issues.apache.org/jira/browse/STRATOS-170
>             Project: Stratos
>          Issue Type: Improvement
>    Affects Versions: 4.0.0 M1
>         Environment: Linux Ubuntu 13.10
> OpenJDK 1.7
> Maven 3.0.4
>            Reporter: chris snow
>         Attachments: 0045-Add-maven-enforcer-plugin-to-ensure.patch, pomEnforcer.2.patch,
pomEnforcer.patch
>
>
> `mvn install` results in:
> [ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:2.0.2:compile
(default-compile) on project org.apache.stratos.load.balancer.extension.api: Compilation failure
> [ERROR] /home/snowc/apache_stratos/incubator-stratos/components/org.apache.stratos.load.balancer.extension.api/src/main/java/org/apache/stratos/load/balancer/extension/api/LoadBalancerExtension.java:[45,5]
error: annotations are not supported in -source 1.3



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message