stratos-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nirmal Fernando (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (STRATOS-170) `mvn install` issue - LoadBalancerExtension.java:[45,5] error: annotations are not supported in -source 1.3
Date Sat, 09 Nov 2013 08:29:17 GMT

    [ https://issues.apache.org/jira/browse/STRATOS-170?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13818072#comment-13818072
] 

Nirmal Fernando commented on STRATOS-170:
-----------------------------------------

Maven3 and JDK 1.6/1.7






-- 
Best Regards,
Nirmal

Nirmal Fernando.
PPMC Member & Committer of Apache Stratos,
Senior Software Engineer, WSO2 Inc.

Blog: http://nirmalfdo.blogspot.com/


> `mvn install` issue - LoadBalancerExtension.java:[45,5] error: annotations are not supported
in -source 1.3
> -----------------------------------------------------------------------------------------------------------
>
>                 Key: STRATOS-170
>                 URL: https://issues.apache.org/jira/browse/STRATOS-170
>             Project: Stratos
>          Issue Type: Improvement
>    Affects Versions: 4.0.0 M1
>         Environment: Linux Ubuntu 13.10
> OpenJDK 1.7
> Maven 3.0.4
>            Reporter: chris snow
>         Attachments: pomEnforcer.patch
>
>
> `mvn install` results in:
> [ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:2.0.2:compile
(default-compile) on project org.apache.stratos.load.balancer.extension.api: Compilation failure
> [ERROR] /home/snowc/apache_stratos/incubator-stratos/components/org.apache.stratos.load.balancer.extension.api/src/main/java/org/apache/stratos/load/balancer/extension/api/LoadBalancerExtension.java:[45,5]
error: annotations are not supported in -source 1.3



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message