stdcxx-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Fox" <fox.micha...@gmail.com>
Subject VCExpress progress
Date Fri, 18 Aug 2006 07:37:26 GMT
When I installed VCExpress I followed the MS install instructions to get the
Platform SDK Windows Server 2003 R2 as well, and to fixup VCExpress config
files. I added the SDK bin to my dosbox path variable so that cscript would
work from the command line.

After untaring stdcxx-incubating-4.1.3.tar I generated the project fresh:
C:\DOCUME~1\mwfox\MYDOCU~1\stl\STDCXX~1.3>generate.bat /BUILDDIR:build_stl
/CONF
IG:VC71

Then edited devenv.exc use VCExpress.exe instead of devenv.exe and ran it:

C:\DOCUME~1\mwfox\MYDOCU~1\stl\STDCXX~1.3>build_stl\build.bat 15s
Summary log was generated in build_stl\\15s\vc71-15s.htm
build complete 

Opening the VC71.sln with VCExpress in the build_stl directory
choked, VCE said it could not find configure.vcproj in
..\build_stl\build_stl\ so some kind of path mix up occurred.

I moved the VC71.sln file from .\STDCXX~1.3\build_stl up to .\STDCXX~1.3,
and tried opening it again. This time the project converted with out error.
Solution 'VC71'(159 projects) is what the VCE says in its Solution Explorer.

I set the active solution configuration to 15s Debug Thread-safe Static, and
did the build. Here is what I got...

1>------ Build started: Project: configure, Configuration: 15s Debug
Thread-safe Static Win32 ------
1>Performing Custom Build Step
1>Microsoft (R) Windows Script Host Version 5.6
1>Copyright (C) Microsoft Corporation 1996-2001. All rights reserved.
1>Configure: Fatal error: Unable to create log file
build_stl\include\15s\config.log
1>Project : error PRJ0019: A tool returned an error code from "Performing
Custom Build Step"
1>Build log was saved at "file://c:\Documents and Settings\mwfox\My
Documents\stl\stdcxx-4.1.3\build_stl\include\15s\BuildLog.htm"
1>configure - 2 error(s), 0 warning(s)
2>------ Build started: Project: .stdlib, Configuration: 15s Debug
Thread-safe Static Win32 ------
3>------ Build started: Project: .rwtest, Configuration: 15s Debug
Thread-safe Static Win32 ------
3>Compiling...
2>Compiling...
3>alg_test.cpp
3>C:\DOCUME~1\mwfox\MYDOCU~1\stl\stdcxx-4.1.3\include\rw/_config.h(29) :
fatal error C1083: Cannot open include file: 'config.h': No such file or
directory

So there was a problem in the custom build step. On the command line from
.\stdcxx-4.1.3 I tried the pre-build step from the configure project
directly:

C:\DOCUME~1\mwfox\MYDOCU~1\stl\stdcxx-4.1.3>cscript
.\etc\config\windows\configure.wsf /SolutionName:"VC71"
/ConfigurationName:"15s Debug Thread-safe Static"
/SrcDir:"C:\DOCUME~1\mwfox\MYDOCU~1\stl\stdcxx-4.1.3\etc\config\src\"
/OutDir:"build_stl\include\15s\"
/IncludeDir:"C:\DOCUME~1\mwfox\MYDOCU~1\stl\stdcxx-4.1.3\include"
/OutFile:"build_stl\include\15s\config.h"
/LogFile:"build_stl\include\15s\config.log"

and it seems to work. This suggests that the .\
stdcxx-4.1.3\build_stl\config.vcproj has some small path issue. I probably
did something wrong when I specified a BUILDDIR for the generate script.
Anyway this will be easy to fix.

Back to the VCE build trying again, this time some files actually compiled. 
It got as far as:

1>------ Build started: Project: .stdlib, Configuration: 15s Debug
Thread-safe Static Win32 ------
2>------ Build started: Project: .rwtest, Configuration: 15s Debug
Thread-safe Static Win32 ------
2>Compiling...
1>Compiling...
2>alg_test.cpp
1>assert.cpp
1>bitset.cpp
2>any.cpp
1>C:\DOCUME~1\mwfox\MYDOCU~1\stl\stdcxx-4.1.3\include\rw/_mutex.h(132) :
error C2065: '_RWSTD_INTERLOCKED_T' : undeclared identifier
1>C:\DOCUME~1\mwfox\MYDOCU~1\stl\stdcxx-4.1.3\include\rw/_mutex.h(132) :
error C2059: syntax error : ')'
1>C:\DOCUME~1\mwfox\MYDOCU~1\stl\stdcxx-4.1.3\include\rw/_mutex.h(135) :
error C2059: syntax error : ')'
1>C:\DOCUME~1\mwfox\MYDOCU~1\stl\stdcxx-4.1.3\include\rw/_mutex.h(138) :
error C2059: syntax error : ','
1>C:\DOCUME~1\mwfox\MYDOCU~1\stl\stdcxx-4.1.3\include\rw/_mutex.h(1355) :
error C3861: 'InterlockedIncrement': identifier not found
1>C:\DOCUME~1\mwfox\MYDOCU~1\stl\stdcxx-4.1.3\include\rw/_mutex.h(1371) :
error C3861: 'InterlockedDecrement': identifier not found
1>C:\DOCUME~1\mwfox\MYDOCU~1\stl\stdcxx-4.1.3\include\rw/_mutex.h(1387) :
error C3861: 'InterlockedExchange': identifier not found
2>cmdopt.cpp
1>catalog.cpp

I expect you guys to insight into why I'm seeing compiler errors, am I
missing an include file or flag somewhere?

Thanks again for all your help.
Mike



Mime
View raw message