stdcxx-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martin Sebor <se...@roguewave.com>
Subject Re: Error with generate.bat
Date Sat, 04 Feb 2006 20:05:53 GMT
Sergio A. Reyes-Peniche wrote:
> Windows 2000 sp4, with WSH upgraded to version 5.6
> stdcxx-4.1.3
> 
> Hi,
> 
> I'm trying to generate the makefiles for stdcxx-4.1.3, and I keep
> getting this error message:
> 
> D:\stdcxx-4.1.3>generate /BUILDDIR:D:\stdcxx-4.1.3\build /CONFIG:VC71
> Solution generation script
> Checking arguments...
> Building directory tree created
> Checking consistence...
> Creating projects...
> D:\stdcxx-4.1.3\etc\config\windows\generate.wsf(17, 6) WshShell.Exec:
> The system cannot
> find the file specified.
> 
> That line and char number correspond to the initial xml section of
> generate.wsf, not to any line of jscript code, and I can't track down
> the real error. I don't have MSVC 7.1 installed, only version 6 (I
> intend to try and build stdcxx with this and other compilers, to see
> how far the build goes, what kind of errors there are, and what level
> of template support does stdcxx require). Is this the origin of the
> error?

Only MSVC 7.1 works with the infrastructure in 4.1.3. Getting MSVC
8.0 to work isn't difficult -- you simply use the Visual Studio 8.0
conversion wizard to convert the solution (and tweak a few compiler
options). But since the solution format is incompatible between
different versions of Visual Studio there is no way to go back
from 7.1 to 6.0. I suspect that adding support for MSVC 6 would be
a challenge (AFAIK, no one has tried it, even though the library
itself was tested with the compiler not too long ago).

I tried MSVC 6 and ran into the same error. It was caused by my
PATH environment variable missing a directory containing the uuidgen
utility that the infrastructure needs. With uuidgen in my PATH the
script successfully generated the MSVC 7.1 solution and all the
projects. The utility comes with MSVC 8 but I'm sure you can
download it separately as well. As I said, though, the 7.1 solution
will not work with 6.0.

That being said, the error message in this case is not descriptive
enough and should be improved. I created an issue in our bug tracking
database to make sure we don't forget:
http://issues.apache.org/jira/browse/STDCXX-133

Martin

Mime
View raw message