stdcxx-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Martin Sebor (JIRA)" <j...@apache.org>
Subject [jira] Created: (STDCXX-820) [EDG eccp/Solaris 10] config error in prelinker on libm
Date Tue, 01 Apr 2008 20:52:24 GMT
[EDG eccp/Solaris 10] config error in prelinker on libm
-------------------------------------------------------

                 Key: STDCXX-820
                 URL: https://issues.apache.org/jira/browse/STDCXX-820
             Project: C++ Standard Library
          Issue Type: Bug
          Components: Configuration
    Affects Versions: 4.2.0
         Environment: EDG eccp 3.9/Solaris 10
            Reporter: Martin Sebor
            Assignee: Martin Sebor
            Priority: Critical
             Fix For: 4.2.1


The configuration process fails with the vanilla EDG eccp on Solaris 10 (not sure about earlier
versions of the OS) with the following error:

{noformat}
### gmake  config   BUILDMODE=,archive,debug,narrow CONFIG=eccp.config 2>&1 | sed -e
"s/\/build2\/batman\/5.0.0\/builds\/34590601\/source-buildspace\/build/\$(BUILDDIR)/g;s/\/build2\/batman\/5.0.0\/builds\/34590601\/source-buildspace/\$(TOPDIR)/g"
| tee /tmp/build.19875.log:
gmake[1]: Entering directory `$(BUILDDIR)'
gmake[2]: Entering directory `$(BUILDDIR)/include'
gmake config
gmake[3]: Entering directory `$(BUILDDIR)/include'

configuring stdcxx 4.2.0 for eccp-3.9 on sunos-5.10-sparc

checking if the compiler is sane                   ok (invoked with eccp)
checking if the linker is sane                     no

int main () { return 0; }
eccp -D_RWSTDDEBUG -I. -A -x --template_directory=$(BUILDDIR)/lib -g   --display_error_number
--remarks --diag_suppress 193,236,340,401,261,479,487,678,679,815  -c a.cpp -o a.o
eccp a.o --template_directory=$(BUILDDIR)/lib     -lm   -o a.out
library "m" does not exist in the specified library directories
C++ prelinker: error: command line error
gmake[3]: *** [sane] Error 1
gmake[3]: Leaving directory `$(BUILDDIR)/include'
gmake[2]: *** [config.h] Error 2
gmake[2]: Leaving directory `$(BUILDDIR)/include'
gmake[1]: *** [config] Error 2
gmake[1]: Leaving directory `$(BUILDDIR)'
gmake: *** [config] Error 2
{noformat}

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message