stdcxx-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Martin Sebor (JIRA)" <j...@apache.org>
Subject [jira] Commented: (STDCXX-563) split up rw/_mutex.h
Date Thu, 27 Mar 2008 16:15:24 GMT

    [ https://issues.apache.org/jira/browse/STDCXX-563?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12582711#action_12582711
] 

Martin Sebor commented on STDCXX-563:
-------------------------------------

Here are some observations and suggestions regarding the patch:

# Underscores separating components of file names should be replaced with dashes for consistency
with the {{rw/_config-*.h}} headers.
# There's a typo in the name of {{_atomic_aplha.h}}. I suspect the name should be changed
to {{_atomic-deccxx.h}} since the primitives seem specific to the compiler, not to the hardware
architecture.
# What is {{_atomic_generic.h}} for and shouldn't it be merged with {{_atomic.h}}?
# What compilers is {{_atomic_ia64_x64.h}} used by? If all of them on IA64 as well as x86_64
(in LLP64), maybe it should be called {{_atomic-x64.h}}. I see a lof of #ifdefs for MSVC.
Would it make sense to split it up into {{_atomic-msvc.h}} and whatever else?
# I believe {{_atomic_mips.h}} is specific to the MIPSpro compiler and couldn't be used with
gcc on the MIPS architecture. It should be renamed to {{_atomic_mipspro.h}}
# I'm not quite sure what to do with {{_atomic_mutex.h}}. Ideally, we would have atomic operations
everywhere. If there is a platform where we (sometimes) need to use the mutex version (I think
you mentioned PA-RISC) I guess we need to keep it but it doesn't make me very happy...
# If {{_atomic_powerpc.h}} is specific to IBM XLC++ (and can't be used by gcc) it should be
renamed to {{_atomic-xlc.h}}.
# One of {{_atomic-x86.h}} and the [src/i86|http://svn.apache.org/repos/asf/stdcxx/trunk/src/i86]
directory should be renamed for consistency. It seems that the commonly used abbreviation
used for the Intel 8086-derived processors (e.g., 80386, 80486) is x86 -- see the Wikipedia
[article|http://en.wikipedia.org/wiki/X86].
# Would {{_mutex-win32.h}} be a better name than {{_mutex-windows.h}}?

Finally, I wonder if instead of adding suffixes to these files and worry about being consistent
every time we add a new one it would make sense to add platform-specific directories under
{{include/rw/}} instead and move the corresponding files (as well as the {{rw/_config-*.h}}
headers) there. Thoughts?

> split up rw/_mutex.h
> --------------------
>
>                 Key: STDCXX-563
>                 URL: https://issues.apache.org/jira/browse/STDCXX-563
>             Project: C++ Standard Library
>          Issue Type: Improvement
>          Components: Build
>    Affects Versions: 4.2.0
>            Reporter: Martin Sebor
>            Assignee: Farid Zaripov
>             Fix For: 4.2.1
>
>         Attachments: stdcxx-563.patch
>
>   Original Estimate: 4h
>  Remaining Estimate: 4h
>
> The internal header <rw/_mutex.h> has become too big and hard to maintain. It would
be an improvement to split it up into multiple headers, one for each supported implementation
of threads, along the lines of what was done with the <rw/_config.h> header in http://svn.apache.org/viewvc?view=rev&revision=382600.
This is too big to do for 4.2 but simple enough that it could go in 4.2.1.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message