stdcxx-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jeremy Dean" <Jeremy.D...@roguewave.com>
Subject RE: Problem building Standard Library
Date Wed, 06 May 2009 13:42:33 GMT
Turns out they are not getting this error when building the library but
when they are building their application and using the Standard Library.

/illustrate/iplus/source/rw_buildspace/include/rw/_iosfwd.h:176: error:
'_RWSTD_SEEK_SET' was not declared in this scope
/illustrate/iplus/source/rw_buildspace/include/rw/_iosfwd.h:177: error:
'_RWSTD_SEEK_CUR' was not declared in this scope
/illustrate/iplus/source/rw_buildspace/include/rw/_iosfwd.h:178: error:
'_RWSTD_SEEK_END' was not declared in this scope
/illustrate/iplus/source/rw_buildspace/include/rw/_iterbase.h:82: error:
'_RWSTD_PTRDIFF_T' does not name a type
/illustrate/iplus/source/rw_buildspace/include/rw/_iterbase.h:93: error:
'_RWSTD_PTRDIFF_T' does not name a type
/illustrate/iplus/source/rw_buildspace/include/rw/_iterbase.h:104:
error: expected type-specifier before '_RWSTD_PTRDIFF_T' 

Any ideas?

Jeremy

-----Original Message-----
From: Martin Sebor [mailto:msebor@gmail.com] 
Sent: Friday, May 01, 2009 9:13 AM
To: dev@stdcxx.apache.org
Subject: Re: Problem building Standard Library

Jeremy Dean wrote:
>  
>  
> I have a customer on Suse Linux 10update2 that is trying to build 
> apache Standard Library stdcxx-4.2.1.1 (Sourcepro edition 10 update 
> 1).  They are getting the error described in
> http://issues.apache.org/jira/browse/STDCXX-1029
>  
> I recommended that customer reinstall Suse Linux 10.0 as that what was

> certified.  Here are the steps they took, but are still getting the 
> error described:
> 
> We reinstalled Suse Linux 10.2 without GCC 4.1.2. I then installed GCC

> 4.1.0 from the given website. Afterwards, I reinstalled the latest 
> version of SourcePro and built it.
> When we tried building our library again, we still get the 
> _RWSTD_SEEK_SET compile error. So we are using everything as 
> recommended, but the issue still exists. Can you help?

STDCXX-1029 turned out to be invalid. It was caused by using an
installation of gcc configured for another system. As Jakub Jelinek
explains in his comment on gcc bug 37405
   http://gcc.gnu.org/bugzilla/show_bug.cgi?id=37405
gcc must be used on the platform it's configured for. Unless there is a
good reason to do otherwise, it's usually best to use the default
version of gcc that comes with the system.

That said, it's also possible that the error is due to some other
underlying problem. In order to be able to tell, I'd need to see the
actual error (i.e., the build log for the library as well as the
contents of $BUILDDIR/include/config.log).

Martin

> 
> Thanks,
> 
>  
> 
> Jeremy
> 
> Jeremy Dean
> Rogue Wave Software, Inc.
> Technical Support
> Phone: 303-545-3205 -- 1-800-404-4767
> E-mail: support@roguewave.com
> Web: http://www.roguewave.com/support Knowledge Base entries:
> http://www.roguewave.com/kbdocs/search.html
> View issues online at: 
> http://www.roguewave.com/youraccount/login/
> 


Mime
View raw message