stdcxx-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From pendiala jaipal <jaipal_...@yahoo.com>
Subject problem with Apache standard library
Date Tue, 24 Jun 2008 06:40:40 GMT
Hi all,

I built Apache Standard Library (stdcxx-4.2.1) on HPUX with acc 3.80 on 11.23PA platform.
when i create binary using libstd.sl it is giving errors.

I followed these steps:

aCC /home/jaipal/stdcxx-4.2.1/build/include -mt -c -o t.o ex.cpp

aCC /home/jaipal/stdcxx-4.2.1/build/lib -mt t.o  ./libstd.sl  -o prog

it is giving error as  : /usr/ccs/bin/ld: /home/jaipal/Stdcxx/stdcxx-4.2.1.good/build/lib:
Not a valid object file (invalid system id)

if i run  aCC  mt t.o  ./libstd.sl  -o prog
the prog binary is creating.

when i run the binary it is giving error as :

aCC runtime: Error 215 from shl_findsym ( home/jaipal/stdcxx-4.2.1/build/lib/libstd.sl ,_shlInit)'
signal 11


Can you please help me on this issue and also can you tell me how to test this apache standard
library .

Thanks in Advance,
Jaipal Reddy P.






      
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message