stdcxx-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martin Sebor <se...@roguewave.com>
Subject Re: svn commit: r672395 - in /stdcxx/branches/4.3.x/include: functional rw/_ref_wrap.h
Date Mon, 30 Jun 2008 19:19:09 GMT
Eric Lemings wrote:
>  
> 
>> -----Original Message-----
>> From: Martin Sebor [mailto:msebor@gmail.com] On Behalf Of Martin Sebor
>> Sent: Saturday, June 28, 2008 2:51 PM
>> To: dev@stdcxx.apache.org
>> Subject: Re: svn commit: r672395 - in 
>> /stdcxx/branches/4.3.x/include: functional rw/_ref_wrap.h
>>
> ...
>>    5. The definitions of even trivial non-empty functions should
>>       never appear on the same line as the function signature. I.e.,
>>       the above should be:
>>
>>       type& get() const {
>>           _RWSTD_ASSERT (0 != _C_ptr);
> 
> Should we still use integral constant `0' for null pointers when writing
> C++0x code or should we use the new `nullptr' name?  Or (more likely),
> an internal macro aliasing one or the other; e.g., _RWSTD_NULLPTR?

I don't see the need for nullptr in these checks, on the contrary.
It would make the code considerably more verbose and, IMO, harder
to read.

Martin

Mime
View raw message