stdcxx-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martin Sebor <>
Subject Re: [jira] Commented: (STDCXX-810) inconsistent testuite header names
Date Fri, 30 May 2008 23:42:38 GMT
Eric Lemings (JIRA) wrote:
>     [
> Eric Lemings commented on STDCXX-810:
> -------------------------------------
> I noticed the prefix {{rwt_}} used in some places.  As long as we're renaming header
files, wouldn't this prefix further distinguish RWTest headers from other headers (e.g. internal
library headers)?  Or would that be a little too invasive?

That was the original intent of the prefix, but we somehow managed
to drop the 't' (I don't think it was deliberate). AFAIK, there's
just one file that uses the rwt_ prefix. The rest of the driver
uses rw_, so I'd say changing it would definitely be very invasive.


>> inconsistent testuite header names
>> ----------------------------------
>>                 Key: STDCXX-810
>>                 URL:
>>             Project: C++ Standard Library
>>          Issue Type: Improvement
>>          Components: Test Driver
>>    Affects Versions: 4.1.2, 4.1.3, 4.1.4, 4.2.0
>>            Reporter: Martin Sebor
>>            Assignee: Eric Lemings
>>            Priority: Minor
>>             Fix For: 4.3
>>   Original Estimate: 1h
>>  Remaining Estimate: 1h
>> The names of some test suite headers start with the {{rw_}} prefix (such as [rw_alarm.h|])
but others don't follow this convention (e.g., [21.strings.h|]
or [driver.h|]). For consistency,
we should add the {{rw_}} prefix to all test suite headers that are missing it.

View raw message