stdcxx-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martin Sebor <se...@roguewave.com>
Subject Re: ABI problem on Darwin
Date Wed, 30 Apr 2008 22:27:23 GMT
Eric Lemings wrote:
>  
[...]
 > Woops.  You said executable, not library.  So yeah, that's right.  :)

Right.

> Speaking of which, can anyone think of an actual scenario for doing the
> latter?  Just curious.

Deploying an executable linked with 4.2.1 on a system that has
4.2.0 but not 4.2.1 installed.

I agree that people will hardly ever want to replace newer
version with an older one (except when the newer one is worse
that the older). It's that uncommon to deploy programs built
on newer systems on older ones (although not all OS vendors
support this).

Martin

Mime
View raw message