stdcxx-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Martin Sebor (JIRA)" <>
Subject [jira] Updated: (STDCXX-43) names of atomic functions inconsitent
Date Fri, 24 Aug 2007 00:16:30 GMT


Martin Sebor updated STDCXX-43:

    Fix Version/s:     (was: 4.2)

This is mostly done but not complete. Deferred until 4.2.1.

> names of atomic functions inconsitent
> -------------------------------------
>                 Key: STDCXX-43
>                 URL:
>             Project: C++ Standard Library
>          Issue Type: Improvement
>          Components: Build
>    Affects Versions: 4.1.2
>         Environment: all
>            Reporter: Martin Sebor
>            Assignee: Martin Sebor
>            Priority: Trivial
>             Fix For: 4.2.1
> The names of the implementation-specific atomic functions are inconsistent: some contain
the width of the type they operate on (such as __rw_atomic_add32()), others don't (e.g., __rw_atomic_add32()),
and others still follow a different naming convention altogether (e.g., __rw_atomic_incr32()).
This makes understanding and writing the generic overloads that use them (e.g., __rw_atomic_preincrement(),
etc.) difficult and leads to lots of duplicate code in rw/_mutex.h. This is a placeholder
issue to rename these functions using a consistent naming convention and to simplify rw/_mutex.h.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message