stdcxx-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Farid Zaripov" <Farid_Zari...@epam.com>
Subject RE: legacy tests on Windows
Date Fri, 20 Apr 2007 17:04:05 GMT
> -----Original Message-----
> From: Martin Sebor [mailto:sebor@roguewave.com] 
> Sent: Tuesday, March 27, 2007 3:50 AM
> To: stdcxx-dev@incubator.apache.org
> Subject: Re: legacy tests on Windows
> 
> Farid, if this is a simple enough change could you look into 
> it sometime soon? Otherwise, if you're busy let me know and 
> I'll open an issue for it. In any case we need to get these 
> resolved before the release and I'd like us to start getting 
> things to a stable point.

  I have made some changes:
http://svn.apache.org/viewvc?view=rev&rev=530852

Farid.

> 
> Martin Sebor wrote:
> > Andrew Black wrote:
> >> Greetings Martin.
> >>
> >> I think it's likely that we will need to make some changes to the 
> >> windows infrastructure.
> >>
> >> The cause of the missing legacy tests is twofold.  First, 
> the legacy 
> >> test executables appear to fail to compile in dynamic 
> builds because 
> >> the legacy test driver symbols aren't resolved.  This 
> seems to point 
> >> to a failure to export them correctly.
> > 
> > Ah. That's something we need to look into here as the 
> legacy part of 
> > the driver isn't in Subversion
> > 
> >> Second, the runall.wsf script doesn't pass the names of 
> non-existent 
> >> executables to the exec script. Therefore, you don't see 
> any targets 
> >> in the COMPILE or LINK states when the exec utility runs.
> > 
> > IMO, this needs to change. The table must show the status 
> of all the 
> > tests, not just those that compiled and linked successfully.
> > 
> > Unless you see a quick change that your or I could easily make 
> > ourselves I'll ask Farid to do it since he is the expert on the 
> > Windows scripts.
> > 
> >>
> >> Looking at the runall.wsf and generated .stdcxx_runtests 
> solution, I 
> >> believe that the cause of the format messages likely is 
> coming from a 
> >> failure to pass the compatibility mode options to the test suite.
> >> Farid, the additional switches that need to be passed to the exec 
> >> utility when running the tests are '--compat -x "--compat -O -"'
> >> (minus the single quotes).  Hopefully the shell will 
> handle the quote 
> >> processing correctly.
> > 
> > That was suspicion as well. Again, unless you see a quick fix let's 
> > wait for Farid to fix it.
> > 
> > Martin
> > 
> >>
> >> --Andrew Black
> >>
> >> Martin Sebor wrote:
> >>> I noticed that the legacy tests (like 21_native.exe) are reported 
> >>> with the status of FORMAT in some of our most recent 
> results (from 
> >>> this morning) and missing from others.
> >>>
> >>> Andrew, do you have any idea what's going on here? Do we 
> still need 
> >>> to change the Windows test harness to enable the legacy 
> output mode 
> >>> in the driver? What about the builds where they are missing?
> >>>
> >>> Legacy tests with FORMAT status:
> >>> 
> http://people.apache.org/~sebor/stdcxx/results/windows-vista-amd64-m
> >>> svc-64b-8.0-15s-log.gz.txt
> >>>
> >>>
> >>> Missing legacy tests:
> >>> 
> http://people.apache.org/~sebor/stdcxx/results/windows-vista-amd64-m
> >>> svc-64b-8.0-12d-log.gz.txt
> >>>
> >>>
> >>> Thanks
> >>> Martin
> >>
> > 
> 
> 

Mime
View raw message