stdcxx-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martin Sebor <se...@roguewave.com>
Subject Re: question about locales
Date Thu, 12 Apr 2007 16:21:01 GMT
Martin Sebor wrote:
> Patrick Happel wrote:
>> Hello all,
>>   This problem got transferred to me since Jeremy has gone on vacation,
>> and it seems to be continuing.  LOCALE_NAME_FMAT.cpp was edited via a
>> patch supplied by Jeremy, which I assume made the changes described in
>> STDCXX-128.  Here are some more system details:
> 
> Can you post the relevant portion of the config log for the
> config test (we need to see the compilation and link line)?
> If the test compiled successfully, what is its output (when
> run by hand)?
> 
> FYI, if you don't have access to a machine with just the three
> locales you mention you can emulate an environment just like it
> by creating a simple shell script named locale that produces
> the same output and putting it before the system locale utility
> in PATH. Then you can re-run the config test and should be able
> to reproduce the troublesome behavior, including a stack trace.

While looking into this some more I realized that while the
debugging approach I suggested should work with stdcxx 4.1.3
it wouldn't work for the latest test which doesn't rely on
the locale utility anymore (since it may not be installed).

Martin

> 
> Martin
> 
>>
>> Standard Library version 4.1.4
>> Solaris 10, Sun Studio 11 (64 bit)
>>
>> Output of the locale command:
>> dev$locale -a
>> C
>> POSIX
>> iso_8859_1
>>
>> The build error:
>> building library 'stdlib-library' in
>> '/gidev/home/gi/RogueWave/SourcePro/Ed9/source/stdlib/12s'
>> CC -xarch=v9  -D_RWCONFIG=12s -I./../../../include -I./../../.. -I..
>> -D_RWBUILD_std -O -mt -library=%none  -c ../assert.cpp  CC -xarch=v9  
>> -D_RWCONFIG=12s -I./../../../include -I./../../.. -I..
>> -D_RWBUILD_std -O -mt -library=%none  -c ../bitset.cpp  CC -xarch=v9  
>> -D_RWCONFIG=12s -I./../../../include -I./../../.. -I..
>> -D_RWBUILD_std -O -mt -library=%none  -c ../catalog.cpp  CC -xarch=v9  
>> -D_RWCONFIG=12s -I./../../../include -I./../../.. -I..
>> -D_RWBUILD_std -O -mt -library=%none  -c ../codecvt.cpp  
>> "../setlocale.h", line 45: Error: _RWSTD_LC_ALL is not defined.
>>
>>   Any ideas would be appreciated.
>>
>> Thanks,
>>  -Patrick Happel
>>
>> Rogue Wave Software, A QUOVADX(tm) division Technical Support Phone: 
>> 303-545-3205 -- 1-800-404-4767 E-mail: support@roguewave.com
>> Web: http://www.roguewave.com/support
>>
>>
>> -----Original Message-----
>> From: Martin Sebor [mailto:msebor@gmail.com] Sent: Tuesday, April 03, 
>> 2007 11:25 PM
>> To: stdcxx-dev@incubator.apache.org
>> Subject: Re: question about locales
>>
>> Jeremy Dean wrote:
>>> Is there a workaround for not having any locale installed on a machine
>>
>>> other then installing one? The error that comes up is that 
>>> _RWSTD_LC_ALL is undefined.
>>
>> I assume you're running into the same problem as STDCXX-128. The patch
>> referenced in the issue should fix it:
>>    http://issues.apache.org/jira/browse/STDCXX-128
>>
>> If it doesn't, let us know the details of your environment (the version
>> of stdcxx, your compiler, OS, etc.) so we can reproduce it.
>>
>> Martin
>>
>>>  
>>> Jeremy Dean
>>> Rogue Wave Software,
>>> A QUOVADX(tm) division
>>> Technical Support
>>> Phone: 303-545-3205 -- 1-800-404-4767
>>> E-mail: support@roguewave.com
>>> Web: http://www.roguewave.com/support Knowledge Base entries:
>>> http://www.roguewave.com/kbdocs/search.html
>>> View issues online at: http://www.roguewave.com/youraccount/login/
>>>  
>>>
>>
> 


Mime
View raw message