stdcxx-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Brown <mbr...@inbox.com>
Subject Re: strange characters in test output on gnome-terminal
Date Tue, 03 Apr 2007 20:16:00 GMT
> -----Original Message-----
> From: sebor@roguewave.com
> Sent: Mon, 02 Apr 2007 13:09:18 -0600
> To: stdcxx-dev@incubator.apache.org
> Subject: Re: strange characters in test output on gnome-terminal
> 
> What version of Gnome terminal are you using? I couldn't reproduce
> this behavior with Gnome gnome-terminal 2.2.2 (running on Linux).
> I get monochromatic output with no garbage in it suggesting that
> the terminal isn't capable of recognizing the VT100 escape
> sequences (the test driver should be able to detect it and avoid
> using the sequences).

Mine is 2.16.0. It displays ls colors with no problems, it only has trouble with the output
of the tests, not just in the final table but in all output as well. For instance:

$ ./23.list.assign 
# ?[30;mINFO (S1) (10 lines):
# TEXT: 
# COMPILER: gcc 4.1.1, __VERSION__ = "4.1.1 20061011 (Red Hat 4.1.1-30)"
# ENVIRONMENT: amd64/LP64 running linux-elf (unknown release) with glibc 2.5
# FILE: 23.list.assign.cpp
# COMPILED: Apr  3 2007, 13:19:41
# COMMENT: 
############################################################

# CLAUSE: lib.list.assign

# ?[30;mINFO (S1) (3 lines):
# TEXT: std::list<UserPOD>::assign(size_type, const_reference)
# CLAUSE: lib.list.assign
...

-- Mark


> 
> Martin
> 
> Scott Zhong wrote:
>> I am seeing these characters using gnome on opensuse.
>> 
>> Yu (Scott) Zhong
>> 
>> 
>> 
>> -----Original Message-----
>> From: Mark Brown [mailto:mbrown@inbox.com]
>> Sent: Sat 3/31/2007 3:57 PM
>> To: stdcxx-dev@incubator.apache.org
>> Subject: strange characters in test output on gnome-terminal
>> 
>> Hi!
>> 
>> After I switched to a different terminal (gnome-terminal) I see these
>> strange characters when I run stdcxx tests. It seems as though the
>> terminal doesn't interpret the color commands correctly. Has anyone
>> experienced anything like this? Is there a way to get the correct output
>> with this type of terminal, either with colors working or plain?
>> 
>> # +-----------------------+----------+----------+----------+
>> # | DIAGNOSTIC            |  ACTIVE  |   TOTAL  | INACTIVE |
>> # +-----------------------+----------+----------+----------+
>> # | (S1) INFO             |?[30;m       53 |       53 |       0% |
>> # | (S2) NOTE             |        0 |       52 |     100% |
>> # | (S7) ASSERTION        |        0 |     2042 |     100% |
>> # +-----------------------+----------+----------+----------+
>> 
>> -- Mark
>> 
>> ____________________________________________________________
>> Invite Friends to View Your Photo Album and
>> ... Win Free iPods, Movie Tickets or 1GB of Storage.
>> Check it out http://www.inbox.com/win_iPod
>> 

Mime
View raw message