stdcxx-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Brown <>
Subject Cygwin cannot find -lstd12d
Date Fri, 02 Mar 2007 06:15:11 GMT
Hi again,

Sorry about all the emails tonight. I'm sending them out as I run into things. Hopefully they'll
be useful. After the library built all examples are now getting the same error. Looks like
the Cygwin linker can't find the library even though it's there (I checked :)

$ make
gcc -c -I/home/mbrown/stdcxx/include/ansi   -mthreads -D_RWSTD_USE_CONFIG -I/home/mbrown/stdcxx/include
-I/home/mbrown/stdcxx-12d/include -I/home/mbrown/stdcxx/examples/include  -pedantic -nostdinc++
-O2  -W -Wall -Wcast-qual -Winline -Wshadow -Wwrite-strings -Wno-long-long -Wcast-align  

(...lots of warnings about failed inlining...)

gcc accumulate.o -o accumulate -mthreads -L/home/mbrown/stdcxx-12d/lib -lstd12d  -lsupc++
-lcatgets -liconv -lm 
/usr/lib/gcc/i686-pc-cygwin/3.4.4/../../../../i686-pc-cygwin/bin/ld: cannot find -lstd12d
collect2: ld returned 1 exit status
make: *** [accumulate] Error 1

-- Mark

View raw message