stdcxx-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrew Black <abl...@roguewave.com>
Subject Nightly testing failures on AIX 5.3
Date Fri, 01 Dec 2006 17:15:11 GMT
Greetings all.

According to the nightly testing results ( 
http://people.apache.org/~sebor/stdcxx/results/ ), we are observing 
execution failures of the test suite in dynamic builds on AIX 5.3.

To diagnose the issue, I ran a manual build and tried executing a random 
test suite executable (23.bitset).  The following output was produced.

exec(): 0509-036 Cannot load program ./23.bitset because of the 
following errors:
         0509-150   Dependent module librwtest11d.a(shr.o) could not be 
loaded.
         0509-022 Cannot load module librwtest11d.a(shr.o).
         0509-026 System error: A file or directory in the path name 
does not exist.

I believe that the cause of this failure is (my) 
http://svn.apache.org/viewvc?view=rev&rev=480202 subversion change. 
This change defines the SHARED_LDFLAGS make variable to be 
'-Wl,-bsvr4,-R$(LIBDIR)'.  The reason the -bsrv4 switch was used was to 
enable the use of the -R switch.  The -R switch embeds a library search 
path into the generated executable, so that setting the LD_LIBRARY_PATH 
variable is unnecessary.  My suspicion is that the -R switch alters the 
behavior of the linker with regards to both dynamic libraries and static 
archives.

I see two possible solutions to this issue.  The first solution is to 
add the rwtest directory to the path passed to the -R switch.  The 
second solution is to remove the use of the -bsrv4 and -R switches on 
AIX 5.3 (the AIX 5.2 linker doesn't support the switches, necessitating 
http://svn.apache.org/viewvc?view=rev&rev=480679 ).

Thoughts?

--Andrew Black

Mime
View raw message