stdcxx-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeremy Dean <d...@roguewave.com>
Subject RE: Problem building Standard library
Date Wed, 17 May 2006 21:12:27 GMT
I compiled this new test on the system and it also gets a segmentation
fault.

Jremy
 

-----Original Message-----
From: Martin Sebor [mailto:sebor@roguewave.com] 
Sent: Wednesday, May 17, 2006 2:57 PM
To: stdcxx-dev@incubator.apache.org
Subject: Re: Problem building Standard library

Jeremy Dean wrote:
> Looking at the log file, there is not much there other then it seg
faulted:

You might want to try the latest version of the test (i.e., the one that
includes changes made for STDCXX-140):
http://svn.apache.org/viewvc/incubator/stdcxx/trunk/etc/config/src/LOCALE_NA
ME_FMAT.cpp?view=log

Martin

> 
> # /roguewave/SourcePro/test/records/ch13n/11s/locale_name_fmat
> /bin/sh: line 1: 24873 Segmentation fault 
> /roguewave/SourcePro/test/records /ch13n/11s/locale_name_fmat
> 
> Exit status: -117
> 
> 
> Here is the output of gdb:
> 
> (gdb) run
> Starting program:
> /roguewave/SourcePro/test/records/ch13n/11s/locale_name_fmat
> /**/
> #undef _RWSTD_LOCALE_NAME_FMAT
> #define _RWSTD_LC_COLLATE   3
> #define _RWSTD_LC_CTYPE     0
> #define _RWSTD_LC_MONETARY  4
> #define _RWSTD_LC_NUMERIC   1
> #define _RWSTD_LC_TIME      2
> #define _RWSTD_LC_MESSAGES  5
> #define _RWSTD_LC_ALL       6
> #define _RWSTD_LC_MAX      _RWSTD_LC_ALL
> #define _RWSTD_LC_MIN      _RWSTD_LC_CTYPE
> 
> Program received signal SIGSEGV, Segmentation fault.
> 0x00213929 in strcat () from /lib/tls/i686/libc.so.6
> (gdb) where
> #0  0x00213929 in strcat () from /lib/tls/i686/libc.so.6
> #1  0x080492e5 in main ()
>     at
> /roguewave/SourcePro/Ed9/etc/stdlib/config/src/LOCALE_NAME_FMAT.cpp:25
> 1
> 
> Jeremy
> 
> -----Original Message-----
> From: Martin Sebor [mailto:sebor@roguewave.com]
> Sent: Wednesday, May 17, 2006 10:00 AM
> To: stdcxx-dev@incubator.apache.org
> Subject: Re: Problem building Standard library
> 
> Jeremy Dean wrote:
> 
>>I am having a problem building Standard Library.
> 
> [...]
> 
>>When I try to build an optimized build, the localedef hangs and never 
>>returns.
> 
> 
> Have you searched the bug database for similar problems? The 
> configuration issue below causes similar symptoms in locale:
> http://issues.apache.org/jira/browse/STDCXX-140. It's been fixed on 
> the trunk.
> 
> 
>>I was told to then try building a debug version, and the debug version 
>>of the library fails to compile with the following error:
> 
> [...]
> 
>>/roguewave/SourcePro/Ed9/source/stdlib/setlocale.h:45: error:
>>`_RWSTD_LC_ALL' was not declared in this scope
> 
> 
> That's an obvious configuration issue. You need to find out why the 
> test that's supposed to define the macro is failing.
> IIRC, the name of the test is LOCALE_NAME_FORMAT.cpp. Look at the log 
> file to see what went wrong.
> 
> Martin

Mime
View raw message