stdcxx-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martin Sebor <>
Subject Re: Tests for lib.string::find methods
Date Tue, 02 May 2006 00:30:05 GMT
Anton Pevtsov wrote:
> OK, I removed the nres member and renamed res_len to nres.
> Here is new version:

Great! Looks good!

One minor request regarding formatting for readability. In
declarations of the test case arrays I find the following

     static const TestCase
     ptr_test_cases[] = {

more legible than this one:

     static const TestCase ptr_test_cases[] = {

If you agree, could you please adopt that style?

> Also I added verification that traits::length() is really used to the
> append test.
> I think it will be useful to move get_calls functions to the rw_char.h
> or provide
> Another mechanism to retrieve n_calls array or 0, if it is absent in the
> traits type.
> What do you think about this? 

If the get_calls() helper is only being used in one test I'd be
inclined to leave it where it is. If and when we start using it
in other tests we should probably move it to the common header
as you suggest.

> May I commit these changes and add new tests to svn?

With the formatting change (and assuming you agree with the style
change), okay to commit. Please commit the new tests separately from
changes to any existing files.


View raw message