stdcxx-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Liviu Nicoara <>
Subject Re: VACPP 8.0 builds with custom compiler cfg file
Date Mon, 20 Mar 2006 22:21:15 GMT
Martin Sebor wrote:
> Liviu Nicoara wrote:
>> I tried to make a build with VACPP 8.0 on a SUSE box. The setting of "-F
>> <value>" (compiler config location) via compiler/linker options as
>> explained in the README:
>>     "To  change  preprocessor, compiler,  or  linker  options you  can
>>      either set the make variables CPPOPTS, CXXOPTS, and LDOPTS on the
>>      command  line  (recommended,  except   with  HP  aCC)  or  modify
>>      ${BUILDDIR}/  The  second option is  recommended when
>>      compiling  with HP  aCC (as  the compiler  looks  for environment
>>      variables with the same names)."
>> does not work.
> I haven't tried it. What's the problem?

The options are discarded and the build fails with the compiler looking
for the config file in /etc/... . I would like to have the ability to
pass -F as an option.

>> I looked in JIRA and there seems to be no incident describing this
>> situation. I do not want to go the way of modifying
>> Has anyone tried a build like this on such a system?
> Yes. You can edit after the initial build craps out and
> add -F there.

I am going to look into why this doesn't work.


View raw message