stanbol-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yauhen Klimovich <klimovich....@gmail.com>
Subject Re: Ontonet issue: uploading custom ontology via web-interface
Date Thu, 04 Feb 2016 15:32:01 GMT
Hi Alessandro,
thank you for the response,
I’m happy you are back!

so, as you said, the following works:
----
1) Load onto:
curl -u admin:admin -X POST -F "url=http://www.ontologydesignpatterns.org/cp/owl/agentrole.owl"
http://locahostt:9999/ontonet
2) create scope:
curl -u admin:admin -X PUT http://locahostt:9999/ontonet/ontology/test_scope2
3) load onto to created scope
curl -u admin:admin -X POST -H "Content-type: text/plain" -d "http://www.ontologydesignpatterns.org/cp/owl/agentrole.owl”
http://locahost:9999/ontonet/ontology/test_scope2 <http://locahost:9999/ontonet/ontology/test_scope2>
----

So, what I’ve found:
1) loading ontology from web-interface doesn’t work in any case;
2) seems rdf/xml works only, no other formats, but it’s better to check again on another
env.


And finally, after a lot of tries I managed to load my onto from local file.
After creating a scope, I’ve loaded mine onto.owl in rdf format via the following command
(I use port 9999 for stanbol), having scope ‘ronto’ created:

curl -X POST -F file=“@onto.owl" -F format=application/rdf+xml "http://localhost:9999/ontonet/ontology/ronto"
-u “admin"

ok, nice, But

(screenshot is attached) The next issue is how to register my onto as a TripleCollection to
be able to query it via sparql endpoint. References from this page are really lacking of resourceful
information.

Again, it would be really nice to have an example that works.

thank you Alessandro, stanbol developers




> On Feb 4, 2016, at 12:18 PM, Alessandro Adamou <alessandro.adamou@open.ac.uk> wrote:
> 
> Hi Yahuen,
> 
> sorry for the late response to your original request. Been away for a
> few days too.
> 
> Admittedly I am still to catch up on the latest changes in Stanbol so
> currently I don't know what has affected the ontology manager so badly.
> If you tell me you have already tried with HTTP authentication via cURL
> and that used to work but now it doesn't, then something has changed for
> the worse and we need to inspect that.
> 
> Cheers
> 
> Alessandro
> 
> 
> On 03/02/2016 20:03, klim klim wrote:
>> Hi all,
>> is there current documentation available on Stanbol?
>> 
>> env:
>> Stanbol cloned from github (last commit on Oct 29,74887050f761bbfb52ef8e6cd00321f5e56efebf),
built w/ tests successfully)
>> Centos 6.5
>> 
>> So, the issue:
>> Uploading my custom ontology into ontonet.
>> 
>> 1) I tried to upload via web-interface 12Mb owl file in turtle format, I got the
following:
>> HTTP ERROR: 400
>> 
>> Problem accessing /ontonet. Reason:
>> 
>>     Bad Request
>> 
>> Powered by Jetty://
>> 
>> 
>> 2) I created a scope test_scope and went to the page http://../ontonet/ontology/test_scope
<http://../ontonet/ontology/test_scope><http://../ontonet/ontology/test_scope <http://../ontonet/ontology/test_scope>>,
>> and tried to upload the onto file (Load ontology tab -> From a local file) - and
the result is the same HTTP ERROR 400;
>> 
>> 3) I did the same as in 2) but for session and I linked the session to the ’test_scope'.
Here we go http://../ontonet/session/test_session <http://../ontonet/session/test_session>
<http://../ontonet/session/test_session <http://../ontonet/session/test_session>>,
>> I got the same.
>> 
>> 4) I restarted Stanbol w/ -no-security flag and got the same results for each case
(upload from /ontonet, from /ontonet/ontology/test_scope and /ontonet/session/test_session
providing ‘Input format’ as turtle), but again with No luck.
>> 
>> ——
>>  I looked for the solution on the internet and found https://mail-archives.apache.org/mod_mbox/stanbol-dev/201507.mbox/%3C55BB50B6.5010606@open.ac.uk%3E
<https://mail-archives.apache.org/mod_mbox/stanbol-dev/201507.mbox/%3C55BB50B6.5010606@open.ac.uk%3E>
<https://mail-archives.apache.org/mod_mbox/stanbol-dev/201507.mbox/%3C55BB50B6.5010606@open.ac.uk%3E
<https://mail-archives.apache.org/mod_mbox/stanbol-dev/201507.mbox/%3C55BB50B6.5010606@open.ac.uk%3E>>
>> 
>> are there any possible ways to do it from web-interface? I need to teach non-technical
users to do it.
>> 
>> 
>> Also, wrt to the solution provided by Alessandro in the mentioned thread  “Re:
Load ontology to scope -- does not work”, I didn’t manage to adapt it to my case. Can
somebody, please, show me the most up-to-date documentation or give me a workable example
of uploading local file as ontology?
>> 
>> I will really appreciate. thank you for your time
>> 
>> Yauhen
> 
> -- The Open University is incorporated by Royal Charter (RC 000391), an exempt charity
in England & Wales and a charity registered in Scotland (SC 038302). The Open University
is authorised and regulated by the Financial Conduct Authority.


Mime
View raw message