stanbol-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alessandro Adamou <alessandro.ada...@open.ac.uk>
Subject Re: Ontonet issue: uploading custom ontology via web-interface
Date Thu, 04 Feb 2016 11:18:30 GMT
Hi Yahuen,

sorry for the late response to your original request. Been away for a
few days too.

Admittedly I am still to catch up on the latest changes in Stanbol so
currently I don't know what has affected the ontology manager so badly.
If you tell me you have already tried with HTTP authentication via cURL
and that used to work but now it doesn't, then something has changed for
the worse and we need to inspect that.

Cheers

Alessandro


On 03/02/2016 20:03, klim klim wrote:
> Hi all,
> is there current documentation available on Stanbol?
>
> env:
> Stanbol cloned from github (last commit on Oct 29,74887050f761bbfb52ef8e6cd00321f5e56efebf),
built w/ tests successfully)
> Centos 6.5
>
> So, the issue:
> Uploading my custom ontology into ontonet.
>
> 1) I tried to upload via web-interface 12Mb owl file in turtle format, I got the following:
> HTTP ERROR: 400
>
> Problem accessing /ontonet. Reason:
>
>      Bad Request
>
> Powered by Jetty://
>
>
> 2) I created a scope test_scope and went to the page http://../ontonet/ontology/test_scope
<http://../ontonet/ontology/test_scope>,
> and tried to upload the onto file (Load ontology tab -> From a local file) - and the
result is the same HTTP ERROR 400;
>
> 3) I did the same as in 2) but for session and I linked the session to the ’test_scope'.
Here we go http://../ontonet/session/test_session <http://../ontonet/session/test_session>,
> I got the same.
>
> 4) I restarted Stanbol w/ -no-security flag and got the same results for each case (upload
from /ontonet, from /ontonet/ontology/test_scope and /ontonet/session/test_session providing
‘Input format’ as turtle), but again with No luck.
>
> ——
>   I looked for the solution on the internet and found https://mail-archives.apache.org/mod_mbox/stanbol-dev/201507.mbox/%3C55BB50B6.5010606@open.ac.uk%3E
<https://mail-archives.apache.org/mod_mbox/stanbol-dev/201507.mbox/%3C55BB50B6.5010606@open.ac.uk%3E>
>
> are there any possible ways to do it from web-interface? I need to teach non-technical
users to do it.
>
>
> Also, wrt to the solution provided by Alessandro in the mentioned thread  “Re: Load
ontology to scope -- does not work”, I didn’t manage to adapt it to my case. Can somebody,
please, show me the most up-to-date documentation or give me a workable example of uploading
local file as ontology?
>
> I will really appreciate. thank you for your time
>
> Yauhen

-- The Open University is incorporated by Royal Charter (RC 000391), an exempt charity in
England & Wales and a charity registered in Scotland (SC 038302). The Open University
is authorised and regulated by the Financial Conduct Authority.

Mime
View raw message