stanbol-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniele Perlo <perlo.dani...@gmail.com>
Subject Re: SPARQL endpoint gives empty response
Date Wed, 30 Jul 2014 09:18:05 GMT
When i try to send a query to sparql endpoint, (by curl or web
interface), this warning is shown:

Warning: A servlet request to the URI http://localhost:8080/sparql
contains form parameters
in the request body but the request body has been consumed by the
servlet or a servlet filter
accessing the request parameters. Only resource methods using
@FormParam will work as expected.
Resource methods consuming the request body by other means will not
work as expected.



2014-07-26 19:31 GMT+02:00 Daniele Perlo <perlo.daniele@gmail.com>:

> Hi all
>
> i try to run some queries on sparql endpoint but all responses are empty.
>
> So, i tried with the ClerezzaYard example at
> https://stanbol.apache.org/docs/trunk/components/entityhub/managedsite.html
>
> and the web interface example at /sparql
>
> PREFIX fise: <http://fise.iks-project.eu/ontology/>
> PREFIX dc:   <http://purl.org/dc/terms/>
> SELECT distinct ?enhancement ?content ?engine ?extraction_time
> WHERE {
>   ?enhancement a fise:Enhancement .
>   ?enhancement fise:extracted-from ?content .
>   ?enhancement dc:creator ?engine .
>   ?enhancement dc:created ?extraction_time .
> }
> ORDER BY DESC(?extraction_time) LIMIT 5
>
> at
> org.apache.stanbol.contenthub.enhancements
>
> but responses are all the same
>
> <?xml version="1.0" encoding="UTF-8" standalone="no"?>
> <sparql xmlns="http://www.w3.org/2005/sparql-results#">
> <head/>
> <results/>
> </sparql>
>
>
> I'm doing something wrong?
>
> Cheers,
> Daniele
>
>
> --
> *****
>
> *Perlo Daniele*
>



-- 
*****

*Perlo Daniele*

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message