stanbol-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Reto Bachmann-Gmür <r...@apache.org>
Subject Re: [POLL] make "-no-security" the default
Date Fri, 05 Apr 2013 14:18:14 GMT
Hi Danny,

What about having a big "disable security" button in the user manager which
would grey out everything (after a confirm dialog) but leave a "enable
security" button?

Then we could add a command line option that would disable security at
start up.

Technically "disabling security" would just add AllPermission to the
default role.

I think this approach would be better because:
- it's easier to change the settings, even at runtime
- There isn't the possibility to manage users if this has no effect anyway
(as this would be greyed out and disabled)
- The same infrastructure and filters could be running with and without
security (as without security just means "everybody is root" - which
sounds frightening but that's intentional)

Cheers,
Reto


On Fri, Apr 5, 2013 at 3:09 PM, Danny Ayers <danny.ayers@gmail.com> wrote:

> Ok, personally I'd lean towards leaving security on by default, being
> general good practice. But I'm not so familiar with the typical
> applications as everyone else here, so don't take that view too strongly.
>
> But, just a thought: starting up usually needs quite a lengthy command, I
> for one have got it in a script for convenience.
>
> So why not offer a selection of startup scripts, something like:
>
> start.sh
> start.bat
> start-secure.sh
> start-secure.bat
> ...
>
> Cheers,
> Danny.
>
>
>
> On 5 April 2013 14:36, Rupert Westenthaler <rupert.westenthaler@gmail.com
> >wrote:
>
> > On Fri, Apr 5, 2013 at 2:17 PM, Reto Bachmann-Gmür <reto@wymiwyg.com>
> > wrote:
> > > Hi Rupert
> > >
> > >>
> > >> * Disabling Security as default: Stanbol is still not functioning to
> > >> 100% if the Security-Manager is enabled hence IMHO deactivating this
> > >> feature is the logical consequence.
> > >>
> > >
> > > You're referring to the situation when stanbol is started without the
> > > "-no-security" argument but without the authentication bundles?
> > >
> >
> > Including the Security Modules, but with -no-security as default
> > (basically by adding an option -enable-security)
> >
> >
> > > What's not functioning?
> > >
> > > *Want To Fix*
> >
> > The dev.iks-project.eu server was running for some time with security
> > enabled. From what I can remember all Engines for remote services
> > where failing because they where not allowed to connect to those hosts
> > - Zemanta, Calai, Celi, Spotlight. I would also expect the
> > FileContentItem implementation (enhancer.core) to fail creating the
> > temporary files. The EntityDereferencer and EntitySearcher
> > implementation of the Entityhub for SPARQL and CoolURI
> > (entityhub.site.linkeddata). But there might be additional one -
> > especially from other Stanbol Components (e.g. the CMS Adapter might
> > be affected)
> >
> > best
> > Rupert
> >
> > >
> > > Reto
> >
> >
> >
> > --
> > | Rupert Westenthaler             rupert.westenthaler@gmail.com
> > | Bodenlehenstraße 11                             ++43-699-11108907
> > | A-5500 Bischofshofen
> >
>
>
>
> --
> http://dannyayers.com
>
> http://webbeep.it  - text to tones and back again
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message