stanbol-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Lopez <alo...@flordeutopia.pt>
Subject Re: Failed tests (Cache dbpediaDefaultdata Index is currently not active) during fresh "clean install" of r1156651
Date Tue, 16 Aug 2011 10:44:51 GMT
Thanks Rupert, see in-line answers:

> Hi Alex
>
> There is no need to build your own index for testing/using Apache
> Stanbol. A default index is provided within the launcher jar and
> installed during the first start of Stanbol. Building indexes is an
> advanced feature that is not required for setting up Stanbol but
> typically used by users that want to customize existing indexes (e.g.
> including more entities, additional languages ...) or to build there
> own indexes (e.g. of a company thesaurus).
>
> Based on the information you provided I think that there was an error
> either (1) during the build of the
> "org.apache.stanbol.data.sites.dbpedia.default" bundle or during the
> (2) startup Stanbol instance used for the integration test.
>
> for (1) please check if the bundle located in
>
>      {stanbol-root}/data/sites/dbpediadefault/org.apache.stanbol.data.sites.dbpedia.default-1.0.1-incubating.jar

The file is there and is about 17MB.

>
> is about 17 MByte in size. If it is smaller than that something went
> wrong while downloading the data for the default dbpedia index during
> the build process. If this is the case you could try to
>
> * delete data/sites/dbpediadefault/src/main/resources/org/apache/stanbol/data/site/dbpedia/default/index/dbpedia_43k.solrindex.zip
> * rebuild this bundle by calling "mvn clean install" within
> "stanbol-root}/data/sites/dbpediadefault/"
>
> for looking into (2) it would be very helpful if you could provide the
> log of the stanbol server used for the integration tests because the
> errors you see in the console are mainly client side error messages
> plus some WebApplication level server errors.
>
> The file with the details loggings is located at
>
>      {stanbol-root}/integration-tests/target/launchdir/sling/logs/error.log

I'm sending the file. Today I repeated the tests and everything run 
fine. If I remember well, what I did was:

1- Chekout stanbol r1156651

2- mvn clean install (worth noting, I had an already running tomcat at 
8080): it gave error.

3- Launched stanbol and confirmed everything looked fine:
java -Xmx1g -jar 
/home/alex.lopez/stanbol/launchers/full/target/org.apache.stanbol.launchers.full-0.9.0-incubating-SNAPSHOT.jar

-p 9090

4- mvn install -rf :org.apache.stanbol.integration-tests (still same error)

5- Launched stanbol and did some playing around, analyzed some docs and 
tried to create some local entities.

6- Today I re-tried mvn install -rf 
:org.apache.stanbol.integration-tests, this time without errors. So all 
is fine, but still wanted to know why the errors first and later all OK...

Is this a coincidence? Or having run stanbol (like in 3 and 5) can 
really affect the integration tests? Because it seams to me like IT are 
performed in its own context, right?

Thanks again.

Best,
Alex

>
> I will have a look onto the logs if you can send them.
>
>
> best
> Rupert Westenthaler
>
> On Fri, Aug 12, 2011 at 12:29 PM, Alex Lopez<alopez@flordeutopia.pt>  wrote:
>> Hi Stanbol devs,
>>
>> finally the time has come for me to get my hands dirty with Stanbol.
>>
>> After following instructions in
>> http://incubator.apache.org/stanbol/docs/trunk/ and cheking out r1156651
>> everything goes fine until the Integration Tests:
>>
>> some 27 tests fail, all with same error:
>>
>> Aug 11, 2011 5:31:06 PM com.sun.jersey.spi.container.ContainerResponse
>> logException
>> SEVERE: Mapped exception to response: 500 (Internal Server Error)
>> javax.ws.rs.WebApplicationException:
>> org.apache.stanbol.entityhub.servicesapi.site.ReferencedSiteException:
>> Unable to get Represetnation h  ttp://dbpedia.org/resource/Paris because
>> configured Cache dbpediaDefaultdataIndex is currently not available
>>         at
>> org.apache.stanbol.entityhub.jersey.resource.ReferencedSiteRootResource.getEntityById(ReferencedSiteRootResource.java:231)
>> ...
>>
>> Caused by:
>> org.apache.stanbol.entityhub.servicesapi.site.ReferencedSiteException:
>> Unable to get Represetnation http://dbpedia.org/resource  /Paris because
>> configured Cache dbpediaDefaultdataIndex is currently not available
>>         at
>> org.apache.stanbol.entityhub.core.impl.ReferencedSiteImpl.getEntity(ReferencedSiteImpl.java:477)
>>
>>
>> So my guess is that some solr dbpedia indexes are missing (re.:
>> http://mail-archives.apache.org/mod_mbox/incubator-stanbol-dev/201106.mbox/%3CBANLkTimwpuVmD0-fjzh9Q=qEKOxc2xQ8wQ@mail.gmail.com%3E
>> ) but reading the README at stanbol/data/sites/dbpedia it mentions that the
>> index is no longer required and has been replaced by the indexing tool. Can
>> you confirm that I have to follow instructions at
>> stanbol/entityhub/indexing/dbpedia/README.md to build the indexes myself?
>> (that this is not suposed to be part of the normal stanbol "clean install"
>> procedure).
>>
>> Sorry if this is a dumb question, just want to be sure that I'm doing things
>> right.
>>
>> Many thanks, and good day.
>>
>> Alex
>>
>
>
>

Mime
View raw message