sqoop-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Szabolcs Vasas (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SQOOP-3104) Create test categories instead of test suites and naming conventions
Date Wed, 30 Aug 2017 08:00:24 GMT

    [ https://issues.apache.org/jira/browse/SQOOP-3104?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16146845#comment-16146845
] 

Szabolcs Vasas commented on SQOOP-3104:
---------------------------------------

I converted this JIRA to a subtask of SQOOP-3228 since we require this to be able to group
the tests by database dependencies.
Let's assume we want to execute MySQL third party tests only, in that case we only need to
start up a MySQL instance in docker container the rest of the databases are not necessary.

> Create test categories instead of test suites and naming conventions
> --------------------------------------------------------------------
>
>                 Key: SQOOP-3104
>                 URL: https://issues.apache.org/jira/browse/SQOOP-3104
>             Project: Sqoop
>          Issue Type: Sub-task
>            Reporter: Anna Szonyi
>
> We are currently unsing test naming conventions to differentiate between ManualTests,
Unit tests and 3rd party tests.
> Instead of this, we should use junit4 categories, so it's clear by looking at a test
where it fits. This would also remove the reliance on the test class name.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message