Thanks so much for your prompt reply! Wow, wish I'd know that command a few days ago. I think I will be rolling now once I get around some proxy issues.

-Terry


On 09/13/2017 11:07 AM, Michael Ridley wrote:
Sounds like you are missing the impyla library.  The Python library requirements are in https://github.com/apache/incubator-spot/blob/master/spot-oa/requirements.txt

Can you try pip install -r  spot-oa/requirements.txt ?



On Wed, Sep 13, 2017 at 10:58 AM, Terry Healy <thealy@bnl.gov> wrote:
I'm in the process of upgrading our SPOT installation to V1.0 and have ingest and ML running. Hitting a snag on OA after installing several layers of missing packages. I'm getting the error below and not being a Python guy, I'm at full stop. Any
suggestions appreciated.

[spot@hd3:~/apache-spot-1.0-incubating/spot-oa/oa]# python2.7 start_oa.py -d 20170911 -t flow -l 3000
2017-09-12 17:14:47,002 - OA - INFO - -------------------- STARTING OA ---------------------
2017-09-12 17:14:47,002 - OA - INFO - Validating input parameter values
Traceback (most recent call last):
  File "start_oa.py", line 82, in <module>
    main()
  File "start_oa.py", line 40, in main
    start_oa(args)
  File "start_oa.py", line 51, in start_oa
    module = __import__("{0}.{0}_oa".format(args.type),fromlist=['OA'])
  File "/home/spot/apache-spot-1.0-incubating/spot-oa/oa/flow/flow_oa.py", line 30, in <module>
    import api.resources.impala_engine as impala
  File "../api/resources/impala_engine.py", line 17, in <module>
    from impala.dbapi import connect

ImportError: No module named impala.dbapi

Thanks,
Terry



--
Michael Ridley <mridley@cloudera.com>
office: (650) 352-1337
mobile: (571) 438-2420
Senior Solutions Architect
Cloudera