spark-reviews mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From vanzin <...@git.apache.org>
Subject [GitHub] spark issue #18805: [SPARK-19112][CORE] Support for ZStandard codec
Date Fri, 13 Oct 2017 17:57:49 GMT
Github user vanzin commented on the issue:

    https://github.com/apache/spark/pull/18805
  
    ```
    $ ldd linux/amd64/libzstd-jni.so 
    ldd: warning: you do not have execution permission for `linux/amd64/libzstd-jni.so'
    linux/amd64/libzstd-jni.so: /lib64/libc.so.6: version `GLIBC_2.14' not found (required
by linux/amd64/libzstd-jni.so)
            linux-vdso.so.1 =>  (0x00007ffe0dfda000)
            libc.so.6 => /lib64/libc.so.6 (0x00007f89eb3a4000)
            /lib64/ld-linux-x86-64.so.2 (0x0000003612e00000)
    ```
    
    Mystery solved; library is compiled with a newer glibc requirement than the amplab machines
have. Can we ask them to tweak their compilation to support older Linux distros?
    
    ```
    $ cat /etc/issue
    CentOS release 6.9 (Final)
    ```



---

---------------------------------------------------------------------
To unsubscribe, e-mail: reviews-unsubscribe@spark.apache.org
For additional commands, e-mail: reviews-help@spark.apache.org


Mime
View raw message