spark-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SPARK-26427) Upgrade Apache ORC to 1.5.4
Date Fri, 21 Dec 2018 18:02:00 GMT

    [ https://issues.apache.org/jira/browse/SPARK-26427?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16726945#comment-16726945
] 

ASF GitHub Bot commented on SPARK-26427:
----------------------------------------

dongjoon-hyun opened a new pull request #23364: [SPARK-26427][BUILD] Upgrade Apache ORC to
1.5.4
URL: https://github.com/apache/spark/pull/23364
 
 
   ## What changes were proposed in this pull request?
   
   This PR aims to update Apache ORC dependency to the latest version 1.5.4 released at Dec.
20. ([Release Notes](https://issues.apache.org/jira/secure/ReleaseNote.jspa?projectId=12318320&version=12344187]))
   ```
   [ORC-237] - OrcFile.mergeFiles Specified block size is less than configured minimum value
   [ORC-409] - Changes for extending MemoryManagerImpl
   [ORC-410] - Fix a locale-dependent test in TestCsvReader
   [ORC-416] - Avoid opening data reader when there is no stripe
   [ORC-417] - Use dynamic Apache Maven mirror link
   [ORC-419] - Ensure to call `close` at RecordReaderImpl constructor exception
   [ORC-432] - openjdk 8 has a bug that prevents surefire from working
   [ORC-435] - Ability to read stripes that are greater than 2GB
   [ORC-437] - Make acid schema checks case insensitive
   [ORC-411] - Update build to work with Java 10.
   [ORC-418] - Fix broken docker build script
   ```
   
   ## How was this patch tested?
   
   Build and pass Jenkins.

----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on GitHub and use the
URL above to go to the specific comment.
 
For queries about this service, please contact Infrastructure at:
users@infra.apache.org


> Upgrade Apache ORC to 1.5.4
> ---------------------------
>
>                 Key: SPARK-26427
>                 URL: https://issues.apache.org/jira/browse/SPARK-26427
>             Project: Spark
>          Issue Type: Bug
>          Components: Build
>    Affects Versions: 3.0.0
>            Reporter: Dongjoon Hyun
>            Priority: Major
>
> This issue aims to update Apache ORC dependency to the latest version 1.5.4 released
at Dec. 20. ([Release Notes|https://issues.apache.org/jira/secure/ReleaseNote.jspa?projectId=12318320&version=12344187])
> {code}
> [ORC-237] - OrcFile.mergeFiles Specified block size is less than configured minimum value
> [ORC-409] - Changes for extending MemoryManagerImpl
> [ORC-410] - Fix a locale-dependent test in TestCsvReader
> [ORC-416] - Avoid opening data reader when there is no stripe
> [ORC-417] - Use dynamic Apache Maven mirror link
> [ORC-419] - Ensure to call `close` at RecordReaderImpl constructor exception
> [ORC-432] - openjdk 8 has a bug that prevents surefire from working
> [ORC-435] - Ability to read stripes that are greater than 2GB
> [ORC-437] - Make acid schema checks case insensitive
> [ORC-411] - Update build to work with Java 10.
> [ORC-418] - Fix broken docker build script
> {code}



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@spark.apache.org
For additional commands, e-mail: issues-help@spark.apache.org


Mime
View raw message