spark-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hyukjin Kwon (JIRA)" <j...@apache.org>
Subject [jira] [Assigned] (SPARK-26422) Unable to disable Hive support in SparkR when Hadoop version is unsupported
Date Fri, 21 Dec 2018 08:12:00 GMT

     [ https://issues.apache.org/jira/browse/SPARK-26422?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Hyukjin Kwon reassigned SPARK-26422:
------------------------------------

    Assignee: Hyukjin Kwon

> Unable to disable Hive support in SparkR when Hadoop version is unsupported
> ---------------------------------------------------------------------------
>
>                 Key: SPARK-26422
>                 URL: https://issues.apache.org/jira/browse/SPARK-26422
>             Project: Spark
>          Issue Type: Bug
>          Components: SparkR
>    Affects Versions: 3.0.0
>            Reporter: Hyukjin Kwon
>            Assignee: Hyukjin Kwon
>            Priority: Major
>             Fix For: 2.3.3, 2.4.1, 3.0.0
>
>
> When we make a Spark session as below:
> {code}
> sparkSession <- sparkR.session("local[4]", "SparkR", Sys.getenv("SPARK_HOME"),
>                                list(spark.driver.extraClassPath = jarpaths,
>                                     spark.executor.extraClassPath = jarpaths),
>                                enableHiveSupport = FALSE)
> {code}
> I faced an issue that it's unable to disable Hive support explicitly with the error below:
> {code}
> java.lang.reflect.InvocationTargetException
> ...
> Caused by: java.lang.IllegalArgumentException: Unrecognized Hadoop major version number:
3.1.1.3.1.0.0-78
> 	at org.apache.hadoop.hive.shims.ShimLoader.getMajorVersion(ShimLoader.java:174)
> 	at org.apache.hadoop.hive.shims.ShimLoader.loadShims(ShimLoader.java:139)
> 	at org.apache.hadoop.hive.shims.ShimLoader.getHadoopShims(ShimLoader.java:100)
> 	at org.apache.hadoop.hive.conf.HiveConf$ConfVars.<clinit>(HiveConf.java:368)
> 	... 43 more
> Error in handleErrors(returnStatus, conn) :
>   java.lang.ExceptionInInitializerError
> 	at org.apache.hadoop.hive.conf.HiveConf.<clinit>(HiveConf.java:105)
> 	at java.lang.Class.forName0(Native Method)
> 	at java.lang.Class.forName(Class.java:348)
> 	at org.apache.spark.util.Utils$.classForName(Utils.scala:193)
> 	at org.apache.spark.sql.SparkSession$.hiveClassesArePresent(SparkSession.scala:1116)
> 	at org.apache.spark.sql.api.r.SQLUtils$.getOrCreateSparkSession(SQLUtils.scala:52)
> 	at org.apache.spark.sql.api.r.SQLUtils.getOrCreateSparkSession(SQLUtils.scala)
> 	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> 	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
> 	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
> 	at java.lang.reflect.Method.invoke(Method.java:498)
> 	at org.apache.spark.api.r.RBackendHandler.handleMethodCall(RBackendHandler.scala:167)
> 	at org.apache.spark.api.r.RBackendHandler.channelRead0(RBackendHandler.scala:108)
> ...
> {code} 



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@spark.apache.org
For additional commands, e-mail: issues-help@spark.apache.org


Mime
View raw message