spark-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hyukjin Kwon (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SPARK-24568) Code refactoring for DataType equalsXXX methods
Date Sun, 24 Jun 2018 06:29:00 GMT

    [ https://issues.apache.org/jira/browse/SPARK-24568?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16521394#comment-16521394
] 

Hyukjin Kwon commented on SPARK-24568:
--------------------------------------

(Please avoid to set the fix version which is usually set when it's actually fixed)

> Code refactoring for DataType equalsXXX methods
> -----------------------------------------------
>
>                 Key: SPARK-24568
>                 URL: https://issues.apache.org/jira/browse/SPARK-24568
>             Project: Spark
>          Issue Type: Improvement
>          Components: SQL
>    Affects Versions: 2.3.0
>            Reporter: Maryann Xue
>            Priority: Major
>
> Right now there is a lot of code duplication between all DataType equalsXXX methods:
{{equalsIgnoreNullability}}, {{equalsIgnoreCaseAndNullability}}, {{equalsIgnoreCaseAndNullability}},
{{equalsStructurally}}. We can replace the dup code with a helper function.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@spark.apache.org
For additional commands, e-mail: issues-help@spark.apache.org


Mime
View raw message