spark-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ivan Dzikovsky (JIRA)" <j...@apache.org>
Subject [jira] [Created] (SPARK-23780) Failed to use googleVis library with new SparkR
Date Fri, 23 Mar 2018 15:56:00 GMT
Ivan Dzikovsky created SPARK-23780:
--------------------------------------

             Summary: Failed to use googleVis library with new SparkR
                 Key: SPARK-23780
                 URL: https://issues.apache.org/jira/browse/SPARK-23780
             Project: Spark
          Issue Type: Bug
          Components: SparkR
    Affects Versions: 2.2.1
            Reporter: Ivan Dzikovsky


I've tried to use googleVis library with Spark 2.2.1, and faced with problem.

Steps to reproduce:
# Install R with googleVis library.
# Run SparkR:
{code}
sparkR --master yarn --deploy-mode client
{code}
# Run code that uses googleVis:
{code}
library(googleVis)
df=data.frame(country=c("US", "GB", "BR"), 
              val1=c(10,13,14), 
              val2=c(23,12,32))
Bar <- gvisBarChart(df)
cat("%html ", Bar$html$chart)
{code}

Than I got following error message:
{code}
Error : .onLoad failed in loadNamespace() for 'googleVis', details:
  call: rematchDefinition(definition, fdef, mnames, fnames, signature)
  error: methods can add arguments to the generic 'toJSON' only if '...' is an argument to
the generic
Error : package or namespace load failed for 'googleVis'
{code}

But expected result is to get some HTML code output, as it was with Spark 2.1.0.




--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@spark.apache.org
For additional commands, e-mail: issues-help@spark.apache.org


Mime
View raw message