spark-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Xiao Li (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (SPARK-22400) rename some APIs and classes to make their meaning clearer
Date Mon, 30 Oct 2017 17:22:01 GMT

     [ https://issues.apache.org/jira/browse/SPARK-22400?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Xiao Li resolved SPARK-22400.
-----------------------------
       Resolution: Fixed
         Assignee: Zhenhua Wang
    Fix Version/s: 2.3.0

> rename some APIs and classes to make their meaning clearer
> ----------------------------------------------------------
>
>                 Key: SPARK-22400
>                 URL: https://issues.apache.org/jira/browse/SPARK-22400
>             Project: Spark
>          Issue Type: Sub-task
>          Components: SQL
>    Affects Versions: 2.3.0
>            Reporter: Zhenhua Wang
>            Assignee: Zhenhua Wang
>             Fix For: 2.3.0
>
>
> Both `ReadSupport` and `ReadTask` have a method called `createReader`, but they create
different things. This could cause some confusion for data source developers. The same issue
exists between `WriteSupport` and `DataWriterFactory`, both of which have a method called
`createWriter`.
> Besides, the name of `RowToInternalRowDataWriterFactory` is not correct, because it actually
converts `InternalRow`s to `Row`s.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@spark.apache.org
For additional commands, e-mail: issues-help@spark.apache.org


Mime
View raw message