spark-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kris Mok (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SPARK-21927) Spark pom.xml's dependency management is broken
Date Tue, 05 Sep 2017 21:52:00 GMT

    [ https://issues.apache.org/jira/browse/SPARK-21927?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16154426#comment-16154426
] 

Kris Mok commented on SPARK-21927:
----------------------------------

[~sowen] Could you please take a look and see if recent change to POM (e.g. SPARK-14280) would
have caused this issue? Thanks!

> Spark pom.xml's dependency management is broken
> -----------------------------------------------
>
>                 Key: SPARK-21927
>                 URL: https://issues.apache.org/jira/browse/SPARK-21927
>             Project: Spark
>          Issue Type: Bug
>          Components: Build
>    Affects Versions: 2.2.1
>         Environment: Apache Spark current master (commit 12ab7f7e89ec9e102859ab3b710815d3058a2e8d)
>            Reporter: Kris Mok
>
> When building the current Spark master just now (commit 12ab7f7e89ec9e102859ab3b710815d3058a2e8d),
I noticed the build prints a lot of warning messages such as the following. Looks like the
dependency management in the POMs are somehow broken recently.
> {code:none}
> .../workspace/apache-spark/master (master) $ build/sbt clean package
> Attempting to fetch sbt
> Launching sbt from build/sbt-launch-0.13.16.jar
> [info] Loading project definition from .../workspace/apache-spark/master/project
> [info] Updating {file:.../workspace/apache-spark/master/project/}master-build...
> [info] Resolving org.fusesource.jansi#jansi;1.4 ...
> [info] downloading https://repo1.maven.org/maven2/org/scalastyle/scalastyle-sbt-plugin_2.10_0.13/1.0.0/scalastyle-sbt-plugin-1.0.0.jar
...
> [info]     [SUCCESSFUL ] org.scalastyle#scalastyle-sbt-plugin;1.0.0!scalastyle-sbt-plugin.jar
(239ms)
> [info] downloading https://repo1.maven.org/maven2/org/scalastyle/scalastyle_2.10/1.0.0/scalastyle_2.10-1.0.0.jar
...
> [info]     [SUCCESSFUL ] org.scalastyle#scalastyle_2.10;1.0.0!scalastyle_2.10.jar (465ms)
> [info] Done updating.
> [warn] Found version conflict(s) in library dependencies; some are suspected to be binary
incompatible:
> [warn] 
> [warn]     * org.apache.maven.wagon:wagon-provider-api:2.2 is selected over 1.0-beta-6
> [warn]         +- org.apache.maven:maven-compat:3.0.4                (depends on 2.2)
> [warn]         +- org.apache.maven.wagon:wagon-file:2.2              (depends on 2.2)
> [warn]         +- org.spark-project:sbt-pom-reader:1.0.0-spark (scalaVersion=2.10, sbtVersion=0.13)
(depends on 2.2)
> [warn]         +- org.apache.maven.wagon:wagon-http-shared4:2.2      (depends on 2.2)
> [warn]         +- org.apache.maven.wagon:wagon-http:2.2              (depends on 2.2)
> [warn]         +- org.apache.maven.wagon:wagon-http-lightweight:2.2  (depends on 2.2)
> [warn]         +- org.sonatype.aether:aether-connector-wagon:1.13.1  (depends on 1.0-beta-6)
> [warn] 
> [warn]     * org.codehaus.plexus:plexus-utils:3.0 is selected over {2.0.7, 2.0.6, 2.1,
1.5.5}
> [warn]         +- org.apache.maven.wagon:wagon-provider-api:2.2      (depends on 3.0)
> [warn]         +- org.apache.maven:maven-compat:3.0.4                (depends on 2.0.6)
> [warn]         +- org.sonatype.sisu:sisu-inject-plexus:2.3.0         (depends on 2.0.6)
> [warn]         +- org.apache.maven:maven-artifact:3.0.4              (depends on 2.0.6)
> [warn]         +- org.apache.maven:maven-core:3.0.4                  (depends on 2.0.6)
> [warn]         +- org.sonatype.plexus:plexus-sec-dispatcher:1.3      (depends on 2.0.6)
> [warn]         +- org.apache.maven:maven-embedder:3.0.4              (depends on 2.0.6)
> [warn]         +- org.apache.maven:maven-settings:3.0.4              (depends on 2.0.6)
> [warn]         +- org.apache.maven:maven-settings-builder:3.0.4      (depends on 2.0.6)
> [warn]         +- org.apache.maven:maven-model-builder:3.0.4         (depends on 2.0.7)
> [warn]         +- org.sonatype.aether:aether-connector-wagon:1.13.1  (depends on 2.0.7)
> [warn]         +- org.sonatype.sisu:sisu-inject-plexus:2.2.3         (depends on 2.0.7)
> [warn]         +- org.apache.maven:maven-model:3.0.4                 (depends on 2.0.7)
> [warn]         +- org.apache.maven:maven-aether-provider:3.0.4       (depends on 2.0.7)
> [warn]         +- org.apache.maven:maven-repository-metadata:3.0.4   (depends on 2.0.7)
> [warn] 
> [warn]     * cglib:cglib is evicted completely
> [warn]         +- org.sonatype.sisu:sisu-guice:3.0.3                 (depends on 2.2.2)
> [warn] 
> [warn]     * asm:asm is evicted completely
> [warn]         +- cglib:cglib:2.2.2                                  (depends on 3.3.1)
> [warn] 
> [warn] Run 'evicted' to see detailed eviction warnings
> {code}



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@spark.apache.org
For additional commands, e-mail: issues-help@spark.apache.org


Mime
View raw message