spark-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Felix Cheung (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (SPARK-21367) R older version of Roxygen2 on Jenkins
Date Tue, 11 Jul 2017 06:29:00 GMT

    [ https://issues.apache.org/jira/browse/SPARK-21367?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16081720#comment-16081720
] 

Felix Cheung edited comment on SPARK-21367 at 7/11/17 6:28 AM:
---------------------------------------------------------------

I'm not sure exactly why yet, but comparing the working and non-working build

working:
{code}
First time using roxygen2 4.0. Upgrading automatically...
Writing SparkDataFrame.Rd
Writing printSchema.Rd
Writing schema.Rd
Writing explain.Rd
...
Warning messages:
1: In check_dep_version(pkg, version, compare) :
  Need roxygen2 >= 5.0.0 but loaded version is 4.1.1
2: In check_dep_version(pkg, version, compare) :
  Need roxygen2 >= 5.0.0 but loaded version is 4.1.1
* installing *source* package 'SparkR' ...
{code}

not working:
{code}
First time using roxygen2 4.0. Upgrading automatically...
There were 50 or more warnings (use warnings() to see the first 50)
* installing *source* package 'SparkR' ...
{code}

Bascially, the .Rd files are not getting created (because of warnings that are not captured)
That cause the CRAN check to fail with 
"checking for missing documentation entries ... WARNING
Undocumented code objects:
  '%<=>%' 'add_months' 'agg' 'approxCountDistinc"

(which would be to be expected)




was (Author: felixcheung):
I'm not sure exactly why yet, but comparing the working and non-working build

working:
{code}
First time using roxygen2 4.0. Upgrading automatically...
Writing SparkDataFrame.Rd
Writing printSchema.Rd
Writing schema.Rd
Writing explain.Rd
...
Warning messages:
1: In check_dep_version(pkg, version, compare) :
  Need roxygen2 >= 5.0.0 but loaded version is 4.1.1
2: In check_dep_version(pkg, version, compare) :
  Need roxygen2 >= 5.0.0 but loaded version is 4.1.1
* installing *source* package 'SparkR' ...
{code}

not working:
{code}
First time using roxygen2 4.0. Upgrading automatically...
There were 50 or more warnings (use warnings() to see the first 50)
* installing *source* package 'SparkR' ...
{code}

Bascially, the .Rd files are not getting created (because of warnings that are not captured)
That cause the CRAN check to fail with 
"checking for missing documentation entries ... WARNING
Undocumented code objects:
  '%<=>%' 'add_months' 'agg' 'approxCountDistinc"
(which would be to be expected)

As explained in the description above, I"m pretty sure these are not in the build a while
ago
"
Warning messages:
1: In check_dep_version(pkg, version, compare) :
  Need roxygen2 >= 5.0.0 but loaded version is 4.1.1
"

> R older version of Roxygen2 on Jenkins
> --------------------------------------
>
>                 Key: SPARK-21367
>                 URL: https://issues.apache.org/jira/browse/SPARK-21367
>             Project: Spark
>          Issue Type: Bug
>          Components: SparkR
>    Affects Versions: 2.3.0
>            Reporter: Felix Cheung
>            Assignee: shane knapp
>
> Getting this message from a recent build.
> https://amplab.cs.berkeley.edu/jenkins/job/SparkPullRequestBuilder/79461/console
> Warning messages:
> 1: In check_dep_version(pkg, version, compare) :
>   Need roxygen2 >= 5.0.0 but loaded version is 4.1.1
> 2: In check_dep_version(pkg, version, compare) :
>   Need roxygen2 >= 5.0.0 but loaded version is 4.1.1
> * installing *source* package 'SparkR' ...
> ** R
> We have been running with 5.0.1 and haven't changed for a year.
> NOTE: Roxygen 6.x has some big changes and IMO we should not move to that yet.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@spark.apache.org
For additional commands, e-mail: issues-help@spark.apache.org


Mime
View raw message